You can not push recent changes to the old ruby ​​website in heroku

To be honest, I'm not a ruby ​​developer. I am working on certain fixes on a ruby ​​website. It is hosted on the Heroku server.

The changes I have made do not imply adding or deleting gems, but only changes in functionality.

I can not push my changes due to the following problems:

remote:! A security vulnerability has been detected in your application.
remote:! To protect your application you must take action. Your request
remote:! He is currently displaying his credentials through a directory that is easy to exploit.
remote:! cross
remote:!
remote:! To protect your application, you must upgrade to the Sprockets version "2.12.5"
remote:! or disable dynamic compilation at run time by configuring:
remote:!
remote:! `` `
remote:! with fig.assets.compile = false #Disble the security vulnerability
remote:! `` `
remote:!
remote:! To read more about this security vulnerability, see this blog post:
remote:! https://blog.heroku.com/rails-asset-pipeline-vulnerability
remote:!
remote:! Push rejected, could not compile the Ruby application.
remote:
remote:! Failed push

Point to highlight, below are the configurations of the website:

Remote: -----> Ruby app detected
Remote: -----> Compiling Ruby / Rails
Remote: your application was upgraded to bundler 1.15.2.
Remote: previously had a successful deployment with bundler 1.11.2.
remote:
Remote: If you see problems related to the bundler version, see:
Remote: https://devcenter.heroku.com/articles/bundler-version
remote:
Remote: -----> Using the Ruby version: ruby-2.0.0
Remote: -----> Installing dependencies using bundler 1.15.2

This version of Ruby is too old and does not hold, and I'm working on Ruby 2.5.3, package 1.15.2 (until this error, I had no idea about the package or its version)

I tried to install the gem as mentioned (Sprockets version "2.12.5"), then I tried to push my changes and I received this error:

remote:
Remote: -----> Ruby app detected
Remote: -----> Compiling Ruby / Rails
Remote: your application was upgraded to bundler 1.15.2.
Remote: previously had a successful deployment with bundler 1.11.2.
remote:
Remote: If you see problems related to the bundler version, see:
Remote: https://devcenter.heroku.com/articles/bundler-version
remote:
Remote: -----> Using the Ruby version: ruby-2.0.0
Remote: -----> Installing dependencies using bundler 1.15.2
Remote: Running: package installation - no development: test - path / package provider - bins provider / package / bin -j4 - implementation
remote: the git source `git: // github.com / seyhunak / twitter-bootstrap-rails.git` uses the` git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the protocol` https` to keep your data safe.
Remote: the source git `git: // github.com / activeadmin / activeadmin.git` uses the protocol` git`, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the protocol` https` to keep your data safe.
Remote: You are trying to install in deployment mode after changing
Remote: your Gemfile. Run `bundle install` elsewhere and add the
Remote: updated Gemfile.lock to version control.
remote:
Remote: the dependencies in your gemfile changed
remote:
Remote: You have added to the Gemfile:
Remote: * pinions (= 2.12.5)
remote: Bundler Output: The git source `git: // github.com / seyhunak / twitter-bootstrap-rails.git` uses the` git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the protocol` https` to keep your data safe.
Remote: the source git `git: // github.com / activeadmin / activeadmin.git` uses the protocol` git`, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the protocol` https` to keep your data safe.
Remote: You are trying to install in deployment mode after changing
Remote: your Gemfile. Run `bundle install` elsewhere and add the
Remote: updated Gemfile.lock to version control.
remote:
Remote: the dependencies in your gemfile changed
remote:
Remote: You have added to the Gemfile:
Remote: * pinions (= 2.12.5)
remote:
remote:!
remote:! Error installing gems through Bundler.
remote:!
remote:! Push rejected, could not compile the Ruby application.
remote:
remote:! Failed push
Remote: Verifying deployment ...
remote:
remote:! Push rejected to any website.

Any ideas on how to proceed next? Right now I'm searching Google for solutions, but then I get more errors. I tried installation package Y package update And I ended up having even more errors:

The source git `git: // github.com / seyhunak / twitter-bootstrap-rails.git` uses the` git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the protocol` https` to keep your data safe.
The source git `git: // github.com / activeadmin / activeadmin.git` uses the` git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the protocol` https` to keep your data safe.
Getting git: //github.com/seyhunak/twitter-bootstrap-rails.git
Getting git: //github.com/activeadmin/activeadmin.git
Getting https://github.com/stripe/stripe-ruby
Getting https://github.com/stefanoverna/activeadmin-dragonfly
Getting https://github.com/stefanoverna/activeadmin-wysihtml5
Obtaining gems metadata from https: //rubygems.org / .......
Obtaining gems metadata from https://rubygems.org/.
Resolving dependencies ...

Everything was red below this point 🙁

Bundler could not find compatible versions for the "actionpack" gem:
In Gemfile:
The rails (= 4.1.5) were resolved to 4.1.5, which depends on
Actionpack (= 4.1.5)

twitter-bootstrap-rails was resolved to 4.0.0, which depends on
Actionpack (~> 5.0,> = 5.0.1)

Bundler could not find compatible versions for gem "activesupport":
In Gemfile:
carrierwave (~> 0.10.0) was resolved to 0.10.0, which depends on
activesupport (> = 3.2.0)

activeadmin-wysihtml5 was resolved to 1.0.0, which depends on
activeadmin-dragonfly was resolved to 0.0.2, which depends on
activeadmin resolved to 2.0.0.alpha, which depends on
kaminari (> = 1.0.1) was resolved to 1.1.1, which depends on
activesupport (> = 4.1.0)

The rails (= 4.1.5) were resolved to 4.1.5, which depends on
activesupport (= 4.1.5)

rspec-rails (= 3.1.0) was resolved to 3.1.0, which depends on
activesupport (> = 3.0)

shoulda-matchers was resolved in 3.1.2, which depends on
activesupport (> = 4.0.0)

slim-rails (= 2.1.5) was resolved to 2.1.5, which depends on
activesupport (> = 3.0, < 4.2)

Bundler could not find compatible versions for gem "coffee-rails":
  In Gemfile:
    coffee-rails (~> 4.0.0)

xray-rails (= 0.1.14) was resolved to 0.1.14, which depends on
coffee railings

Bundler could not find compatible versions for gems "rails":
In Gemfile:
lanes (= 4.1.5)

xray-rails (= 0.1.14) was resolved to 0.1.14, which depends on
Rails (> = 3.1.0)