upgrade – How to fix dependency problems in dpkg?


I have tried upgrading Ubuntu several times and each time it has failed, informing me there are dependency issues.

Each time, I receive this message:

                                      Errors were encountered while processing:
 dms-core
 dms-dr
 dms
 dms-wsgi
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I scroll up, I am told:

dpkg: error processing package dms (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dms-wsgi:
 dms-wsgi depends on dms-core (= 1.0.8.1-1ubuntu2); however:
  Package dms-core is not configured yet.

(The same applies for the other three failed processes, too)

So, naturally, I used:

sudo apt-get -f install

sudo dpkg --configure -a

Though the same message keeps reappearing, and I am not sure where to go from here.