Ubuntu 18.04 – there is no sound in HDMI – HDMI is not visible in ALSA

I can not play the sound on an HDMI connection between my NUC7CJYH4 and my TV.

As I am now completely lost, I would appreciate help on this subject.

I am running a newly installed UBUNTU 18.04.1 (Kernel 4.15.0-42-generic) and have installed the latest daily compilation snapshots of ALSA (from https://code.launchpad.net/~ubuntu-audio-dev/+ file / ubuntu / alsa-daily / + packages, dkms is installed)

When I am running a dual boot system, I tried Windows10 and the sound on HDMI is running. Therefore, I assume that the HW is fine.

cat / proc / asound / cards sample:

0 [PCH            ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH to 0x82310000 irq 133

lspci -v shows for audio:

00: 0e.0 Multimedia audio driver: Intel Corporation Device 3198 (rev 03)
Subsystem: Intel Corporation 2072 Device
Flags: bus master, fast devsel, latency 0, IRQ 133
Memory in 82310000 (64 bits, not prefilable) [size=16K]
    Memory to 82000000 (64 bits, not selectable) [size=1M]
    Capacities: 
    Kernel driver in use: snd_hda_intel
Core modules: snd_soc_skl, snd_hda_intel

Here is the output of aplay -l:

**** List of hardware playback devices ****
Card 0: PCH [HDA Intel PCH], device 0: analog ALC233 [ALC233 Analog]
  Sub-services: 1/1
Sub device # 0: subsystem # 0
Card 0: PCH [HDA Intel PCH], device 1: ALC233 Digital [ALC233 Digital]
  Sub-services: 1/1
Sub device # 0: subsystem # 0

Compared to other descriptions of problems in various forums, I can not find the HDMI device in this list to begin with.

Pavucontrol only shows the analog and digital output in the Configuration tab, there is no HDMI either.

Disconnecting and re-plugging the HDMI cable and several restarts did not change the situation.

aplay -L does not show HDMI either:

default
Playback / recording through PulseAudio sound server
null
Discard all samples (reproduction) or generate zero samples (capture)
pulse
PulseAudio sound server
sysdefault: CARD = PCH
HDA Intel PCH, ALC233 Analog
Default audio device
Front: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
Front speakers
surround21: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
2.1 Surround sound output for front speakers and subwoofer
surround40: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
Surround output 4.0 for front and rear speakers
surround41: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
4.1 Surround output for front, rear and subwoofer speakers
surround50: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
5.0 surround sound output for front, center and rear speakers
surround51: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
5.1 surround sound output for front, center, rear and subwoofer speakers
surround71: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
7.1 surround sound output for front, center, side, rear and woofer speakers
iec958: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Digital
Digital audio output IEC958 (S / PDIF)
dmix: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
Direct sample mixing device
dmix: CARD = PCH, DEV = 1
HDA Intel PCH, ALC233 Digital
Direct sample mixing device
dsnoop: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
Direct sampling device
dsnoop: CARD = PCH, DEV = 1
HDA Intel PCH, ALC233 Digital
Direct sampling device
hw: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
Direct hardware device without conversions.
hw: CARD = PCH, DEV = 1
HDA Intel PCH, ALC233 Digital
Direct hardware device without conversions.
plughw: CARD = PCH, DEV = 0
HDA Intel PCH, ALC233 Analog
Hardware device with all software conversions.
plughw: CARD = PCH, DEV = 1
HDA Intel PCH, ALC233 Digital
Hardware device with all software conversions.

I checked the contents of / proc / asound / card0 / codecs *:

cat / proc / asound / card0 / codec * | grep HDMI:

Codec: Intel Geminilake HDMI
Pincap 0x09000094: OUT Detect HBR HDMI DP
Default pin 0x18560010: [Jack] Digital output on HDMI Int

cat / proc / asound / card0 / codec * | codec grep sample:

Codec: Realtek ALC233
Codec: Intel Geminilake HDMI

To complete my alsa-base.conf file:

# autoloader alias
install sound-slot-0 / sbin / modprobe snd-card-0
install sound-slot-1 / sbin / modprobe snd-card-1
install sound-slot-2 / sbin / modprobe snd-card-2
install sound-slot-3 / sbin / modprobe snd-card-3
install sound-slot-4 / sbin / modprobe snd-card-4
install sound-slot-5 / sbin / modprobe snd-card-5
install sound-slot-6 / sbin / modprobe snd-card-6
install sound-slot-7 / sbin / modprobe snd-card-7

# Makes the optional modules load on top of the generic modules
install snd / sbin / modprobe --ignore-install snd $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-ioctl32; / sbin / modprobe --quiet --use-blacklist snd-seq; }
#
# Solution to error # 499695 (reverted in Ubuntu see LP # 319505)
install snd-pcm / sbin / modprobe - ignore-install snd-pcm $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-pcm-oss; : }
install snd-mixer / sbin / modprobe --image install snd-mixer $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-mixer-oss; : }
install snd-seq / sbin / modprobe --image install snd-seq $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-seq-midi; / sbin / modprobe --quiet --use-blacklist snd-seq-oss; : }
#
install snd-rawmidi / sbin / modprobe - install-install snd-rawmidi $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-seq-midi; : }
# Makes the optional modules load over the sound card driver modules
install snd-emu10k1 / sbin / modprobe - ignore-install snd-emu10k1 $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-emu10k1-synth; }
install snd-via82xx / sbin / modprobe - ignore-install snd-via82xx $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist snd-seq; }

# Load saa7134-alsa instead of saa7134 (which creeps anyway)
install saa7134 / sbin / modprobe --image-install saa7134 $ CMDLINE_OPTS && {/ sbin / modprobe --quiet --use-blacklist saa7134-alsa; : }
# Prevent abnormal drivers from taking index 0
options bt87x index = -2
options cx88_alsa index = -2
options saa7134-alsa index = -2
options snd-atiixp-modem index = -2
options snd-intel8x0m index = -2
options snd-via82xx-modem index = -2
options snd-usb-audio index = -2
snd-usb-caiaq options index = -2
options snd-usb-ua101 index = -2
options snd-usb-us122l index = -2
options snd-usb-usx2y index = -2
# Ubuntu # 62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port = 0x330 fm_port = 0x388
# Prevents snd-pcsp from loading as the first sound card
options snd-pcsp index = -2
# Keep snd-usb-audio loaded as first sound card
options snd-usb-audio index = -2

Can anyone give me advice on what to do?