performance difference between "REGEXP_REPLACE ()" and "NOT REGEXP_LIKE ()" in ORACLE PL-SQL

I have a Table(Customer_Num number) with approximately 100 million records. I want to know if there is any difference between these two queries in terms of performance:

Query-1:

select *
from Table
where REGEXP_REPLACE(Customer_Num, '(0-9)', '') IS NOT NULL

Query-2:

select *
from Table 
where not regexp_like(Customer_Num, '(^(:digit:))')

Thanks in advance.

views: Which operator is equivalent to "Not greater than or equal to"?

I have a view that shows a list of events. Events are sorted by a date field, which a user can use to enter the event start date / time. However, I want the events to be removed from the list once the current time is 1 hour after the event start date / time. When I add the event date to the view filters, I get the following operators.

enter the image description here

However, none of these operators gives me the desired result. What I really want is a "Not greater than or equal to" operator. Having said all that, is there any workaround that you can easily implement to get the desired result?

Firewall: Why is the Windows Security Alert dialog box defaulted to "not recommended"?

When I start a program that wants network communication for the first time, this dialog box appears:

Windows Defender Firewall Blocking Dialog

It's been a part of Windows for a while now (this runs on Windows 10, but note the Vista / 7 design language), and as far as I know the Public Networks option is checked by default. But according to the text, I don't understand this:

Allow (the application) to communicate on these networks:

() Private networks, such as my home or work network

(X) Public networks … (not recommended because these networks often have little or no security)

Why would the not recommended choice? Since people tend to click first, ask questions later (including myself, every once in a while), this seems like an obvious security hole: to perform the recommended action, I need to check the first box, uncheck the second one, and then click the Allow access box. However, this appears to have been unquestioned or unchanged for several years.

Am I misinterpreting this dialog or is there a legitimate reason for your default choice?

"in" and "not in"

This program only prints that the letter entered by the user is a consonant, even when it is a vowel. I think it has to do with "inside" and "not inside", but I'm not sure and don't even know why that could be.

mensagem= list (input ("Digite qualquer letran"))
vogais = ('a', 'e', 'i', 'o', 'u')

if mensagem in vogais :
    print ("A letra é uma vogal")
if mensagem not in vogais :
    print ("A letra é uma consoante")

Error message with StringReplace "Not a valid string replacement rule"

Following an example from my lectures, I get this error and can't explain why it occurs.

The instructions are as follows:

alphabet = CharacterRange("A","Z");
string = "THIS IS THE TEXT TO ENCRYPT"
rc = RandomColor(26)
code = Table(alphabet((n))->rc((n)),{n,Length(alphabet)})
newstring = StringReplace(string, code)

but sometimes (but not always) I get this error: "StringReplace :: srep: Z -> () is not a valid string replacement rule" where () represents a certain color.

Could you help me understand why it happens?

unity – An error with my function: "not all code paths return a value"

So I wrote a function that gets the closest object in my array and then gets the distance to the point where I want to generate another Object, and if the distance is less then the minimum radius around an object, where I don't want to generate something, it is assumed which returns false and otherwise returns true.
But know that I am getting the error that not all code paths return a value. Can anyone help me with that?

bool GetMinDistance(Vector2 Position)
{
    if (DecoreObjects.Length == 0)
    {
        return true;
    }
    else
    {
        float minDistance = Mathf.Infinity;
        foreach (GameObject currentObject in DecoreObjects)
        {
            Vector2 currentObjectPosition = currentObject.transform.position;
            Vector2 VectorDistance = currentObjectPosition - Position;
            float currentDistance = Mathf.Sqrt(VectorDistance.x * VectorDistance.x + VectorDistance.y * VectorDistance.y);

            if (currentDistance < minDistance)
            {
                minDistance = currentDistance;
            }

            if (minDistance > minRadius)
            {
                return true;
            }
            else
            {
                return false;
            }
        }
    }
}

python: why is my program "not responding" when i run it?

Quickly looking at a hello world with pygame, I came to this page.

Here is the code they use:

import pygame, sys
from pygame.locals import *

pygame.init()
DISPLAYSURF = pygame.display.set_mode((400, 300))
pygame.display.set_caption('Hello World!')
while True: # main game loop
    for event in pygame.event.get():
        if event.type == QUIT:
            pygame.quit()
            sys.exit()
    pygame.display.update()

Your program needs to be "alive", this means you need to have a main loop that will handle at least The events that the operating system sends, Windows in your case.

If you don't process these events, Windows will know this and think the program is frozen (i.e. does not respond) You'll also want to make sure you draw something (that's with the last line in the example).

SharePoint Online workflows stuck in internal status "Not started" and anonymous initiator

I experience a very strange problem with SP designer workflows only in a subsite of the entire site collection in SharePoint online. All created workflows suddenly stopped working and new ones don't work too.

  • If the workflow is set to automatically start on the creation / update of the item, it does not
  • If started manually, it remains in the internal state "Not started" and anonymous initiator.

The workflow history list is empty. The workflow columns in the list are not updated with any status.

I found similar problems in the forums but with the local version. Like here and here.

Here too there are more detailed steps to solve a similar problem, but again for places where we have access to the services so that we can restart them.

I tried to republish workflows again, creating a new workflow with just one simple step to write to the history list, workflow without any step. I tried to finish all workflows blocked in the lists using powershell and tried the previous steps again, nothing helped.

Workflows in all other sites collection sites work correctly and the problem is only with one subsite.

The subsite has unique permissions but does not use anonymous access.

linux – Jupyter Hub says simply "not found" and nothing else, leaving it unusable

One of my teammates cloned an Ubuntu 16.04 server on 2 servers in Azure, and since then our Jupyter Hub has had problems. If I connect to Jupyter Hub at http: // localhost: 8000 / (through an ssh tunnel) it simply says "Not found" and nothing else in the browser.

I think we are using Jupyter Hub 1.0.0, but jupyterhub –version generates that version aspect string and then a crawl. ISTR that is considered benign.

The / var / log check with a recursive grep was not informative.

If I follow the process by listening on tcp / 8000, I can see:

(pid 30739) read(20, "GET / HTTP/1.1rnHost: localhost:8000rnConnection: keep-alivernPragma: no-cachernCache-Control: no-cachernUpgrade-Insecure-Requests: 1rnUser-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36rnSec-Fetch-User: ?1rnAccept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3rnSec-Fetch-Site: nonernSec-Fetch-Mode: navigaternAccept-Encoding: gzip, deflate, brrnAccept-Language: en-US,en;q=0.9rnrn", 65536) = 521
(pid 30739) write(1, "00:18:40.279 (ConfigProxy) 33(31merror33(39m: 404 GET / n", 55) = 55
(pid 30739) socket(PF_INET, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, IPPROTO_IP) = 22
(pid 30739) connect(22, {sa_family=AF_INET, sin_port=htons(8081), sin_addr=inet_addr("127.0.0.1")}, 16) = -1 EINPROGRESS (Operation now in progress)
(pid 30739) epoll_ctl(13, EPOLL_CTL_ADD, 22, {EPOLLOUT, {u32=22, u64=22}}) = 0
(pid 30739) epoll_wait(13, ({EPOLLOUT|EPOLLERR|EPOLLHUP, {u32=22, u64=22}}), 1024, 719) = 1
(pid 30739) getsockopt(22, SOL_SOCKET, SO_ERROR, (111), (4)) = 0
(pid 30739) epoll_ctl(13, EPOLL_CTL_DEL, 22, 0x7fffe88bc610) = 0
(pid 30739) close(22)                   = 0
(pid 30739) write(1, "00:18:40.281 (ConfigProxy) 33(31merror33(39m: Failed to get custom error page: Error: connect ECONNREFUSED 127.0.0.1:8081n    at TCPConnectWrap.afterConnect (as oncomplete) (net.js:1129:14) {n  errno: 'ECONNREFUSED',n  code: 'ECONNREFUSED',n  syscall: 'connect',n  address: '127.0.0.1',n  port: 8081n}n", 300) = 300
(pid 30739) writev(20, ({"HTTP/1.1 404 Not FoundrnDate: Wed, 11 Dec 2019 00:18:40 GMTrnConnection: keep-alivernTransfer-Encoding: chunkedrnrn9", 116}, {"rn", 2}, {"Not Found", 9}, {"rn", 2}, {"0rnrn", 5}), 5) = 134

I searched Google for services that would listen to tcp / 8081 (I didn't find anything interesting), and I searched 8081 for / etc / services (I found tproxy), but I didn't find much. tproxy doesn't feel very relevant in a quick google

What is this mysterious service that Jupyter Hub wants to connect to and how can I start it?

Or, more generally, if the tcp / 8081 thing is a red herring: how can I make Jupyter Hub happy again?

Thank you!

security: the HTTP website shows "Not secure" in Chrome

This is a movement to make the web safer. In addition, it protects all visitors to your site. The long-term solution is to implement SSL on your website (s), since all websites will eventually need to adopt the use of SSL certificates.

According to the Google developer blog:

Finally, Chrome will display a Not Safe warning for all published pages.
over HTTP, regardless of whether or not the page contains confidential information
input fields Even if you adopt one of the most specific resolutions
Above, you should plan to migrate your site to use HTTPS for all
pages

You absolutely need an SSL certificate. I am aware of the fact that they are too expensive in almost all registrars. To save some money, the Linux Foundation has a website that offers free SSL certificates, called * https://letsencrypt.org, although this route may be a bit more labor-intensive in terms of installation rather than simply buying Godaddy