install – Big Sur 11.3 : rebuild the index of all installed Macport packages

Following a lot of error messages when I wanted to install a Macport package on my new MacOS book pro Big Sur 11.3, and having no problem on another MacBook with Big Sur 11.3 also, I decided to do a “raw” copy of the directory /opt/local from the working MacBook to the first one with which I have problems.

Now, I would like to rebuild an index of all Macport packages copied on the new MacBook.

Indeed, if I want to install a Macport package, I get :

sudo port search listofitems
Password:
Error: Current platform "darwin 20" does not match expected platform "darwin 19"
Error: If you upgraded your OS, please follow the migration instructions: https://trac.macports.org/wiki/Migration
OS platform mismatch
    while executing
"mportinit ui_options global_options global_variations"
Error: /opt/local/bin/port: Failed to initialize MacPorts, OS platform mismatch

Have I to copy an index file from the working Macport installation of other MacBook on the new one ? I didn’t find such a file.

As you can see above in the error messages, there seems to be a problem of platform :

Error: Current platform "darwin 20" does not match expected platform "darwin 19"

Please, if someone could help me to rebuild the new packages installed, rather copied in a raw way, but I hope this is possible to get this current index file.

Any help would be fine.

Yotacash.com, Four Tariff Packages, Earn Up To 5% Daily

Hello dear members! I want to represent a hew HYIP-project https://yotacash.com
IPB Image

They opened at 31.03.2021 and work excellent! For today they have more than 500 investors.

Their advantages:

Instant registration and depositing, no personal data required
Minimum deposit and payout is only 0.10$, automatic payouts by request
Deposits body withdrawing are allowed
Four tariff packages
Ability to set automatic refback

Payment systems: PM, PayPal, Bitcoin, Ethereum, Litecoin

My deposit is 50$. Package – The Iron(Basic) – 2% daily.
Reduced Size Image

My payouts:

20:19 14.04.21 Receive 385373340 U29817113
YotaCash +1.00 34.66 Received Payment 1.00 USD from account U29817113. Memo: API Payment. Payment ID: yotacash.com_account_239

11:39 16.04.21 Receive 385726850 U29817113
YotaCash +1.63 36.95 Received Payment 1.63 USD from account U29817113. Memo: API Payment. Payment ID: yotacash.com_account_239

11:23 28.04.21 Receive 388554381 U29817113
YotaCash +8.74 43.2 Received Payment 8.74 USD from account U29817113. Memo: API Payment. Payment ID: yotacash.com_account_239

09:53 05.05.21 Receive 390617678 U29817113
YotaCash +7.38 19.7 Received Payment 7.38 USD from account U29817113. Memo: API Payment. Payment ID: yotacash.com_account_239

https://yotacash.com
IPB Image

This post has been edited by Multimetr: May 6 2021, 11:39 AM

Termux – help to installing the boostrap packages

Termux is say unable to install the bootstrap packages in itel 1516 plus pls help me.

packages – CharacterTable for symmetric groups $S_n$ with large $n$

I am looking for a package to generate character tables for symmetric groups $S_n$. At this moment I am using

FiniteGroupData[{"SymmetricGroup", n}, "CharacterTable"]

but it works only for $nleq 10$. Does there exist a package which can be used to get similar results for larger values of $n$?

updating – What is the best practice for handling abandoned packages required by the drupal core?

When I run composer update on a Drupal 9 website, I get this warning:

Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.

A similar question has alreday been asked, answered and accepted on StackOverflow.

To summarise the accepted answer:

  • edit your composer.json and replace the abandoned package with the recommended replacement
  • then run composer update again

However, that answer doesn’t apply in the case of “doctrine/reflection”. When looking into my composer.json, there is no mention of it, so there is nothing to edit.

So I am checking why it is required:

$ composer why doctrine/reflection
doctrine/common          2.13.3  requires  doctrine/reflection (^1.0)   
doctrine/persistence     1.3.8   requires  doctrine/reflection (^1.2)   
drupal/core              9.1.7   requires  doctrine/reflection (^1.1)   
drupal/core-recommended  9.1.7   requires  doctrine/reflection (1.2.2)  

So this abandoned package is required by drupal/core (and others).

Two questions:

  1. Why is the most recent version of drupal/core requiring an abandoned package (instead of its recommended replacement roave/better-reflection)?
  2. What is the best practice for handling abandoned packages required by the drupal core?

Exporting packages containing “Python Code” cells

I created a notebook with Python code cells (evaluated using External Evaluate) as can be created by typing > at the beginning of a cell. (And choosing Python for the external evaluator). I then marked these cells as initialization cells. However, I find that I can’t reliably create packages (I create packages autoamtically using the answer in https://mathematica.stackexchange.com/a/31323/45020). The python cells do become python cells in the package but they get corrupted. It wrongly breaks cells up at any double new line (this can at least be avoided) but also randomly misses text. A cell with

import scipy.optimize
import numpy as np
def stuff():
...

just becomes
import scipy.optimize
import numpy as
def stuff():

and thus gives a syntax error since np is missing. The original notebook file works perfectly and has no such errors.

Is there any reliable way to export? Does everyone have these issues?

Version: “12.1.1 for Linux x86 (64-bit) (June 19, 2020)”


It gets even weirder. There seems to be some randomness to it. Now I managed to (without making changes) export it correctly to a package that does not produce any errors when run from within MMA (i.e. when opening it and running all the cells.) However, when calling it from another notebook using Get I still get a syntax error. I checked and see no syntax error in the cell where it should supposedly be.


It might be related to having set up a custom virtual environment using this answer. However, everything is working perfectly in the notebook. The issues only arise when converting to a package.

sql server 2008 – Can SSIS packages call other SSIS packages in the connection string?

I am running an SSIS package that transfers data from one (SQL2008) server to another (SQL2000). However after P2V conversion the SQL2008 server cannot execute an SSIS package due to a user authentication error.

Lets say the package is called “Transfer-Go”. In the connection string of that package can it call another SSIS package? In the SSIS library there is another package with the same that appears in the string (called Transfer-Now) name The string is below:

Data Source=<IP>;User ID=<user>;Initial Catalog=<db_name>;Provider=SQLNCLI10.1;Persist Security Info=True;OLE DB Services=-13;Auto Translate=False;Application Name=SSIS-<Transfer-Now-name of other SSIS package>-{8ABA18EE-637E-424F-A3F7-F7E4EA50DD9D}<IP.db_name.user>;

So is this SSIS package connection string calling that package?

And if the credentials are wrong in that package could that be why I am unable to authenticate?

Thanks for any input, not a DB/SQL guy at all so I apologize if I sound green here.

macos – Cant update/install homebrew packages with Kaspersky Security Software (Self Signed Cert)

At work we have Kaspersky installed. Kaspersky installs a self signed cert so it can decrypt/inspect web traffic. Chrome and everything works fine except for homebrew. When i try to install/update software this is what i see:

brew install yarn
==> Downloading https://yarnpkg.com/downloads/1.22.10/yarn-v1.22.10.tar.gz
######################################################################## 100.0%##O#- #
curl: (35) error:1400443E:SSL routines:CONNECT_CR_SRVR_HELLO:tlsv1 alert inappropriate fallback
Error: Failed to download resource "yarn"
Download failed: https://yarnpkg.com/downloads/1.22.10/yarn-v1.22.10.tar.gz

Since it appears its a curl issue i tried to create a .curlrc file with insecure but that doesn’t help at all. I’m able to call one of our IT admins over and temporarily turn off web anti-virus but that is starting to be a major pain every time i install/update software. They aren’t, of course, going to allow me to permantely turn it off. I have this issue on no matter what mac i use (one is a m1 based mac and the other is an intel based mac).

Composer require drupal/social_auth_google – Your requirements could not be resolved to an installable set of packages

Previously I got an error with the command

composer require "drupal/social_auth_google:^2.0"

So I tried;

composer require "drupal/social_api:2.x-dev" "drupal/social_auth:2.x-dev" "drupal/social_auth_google:2.x-dev" 

But now composer throws up faults no matter what I do. I tried removing all the “social” entries from composer.json but here are the errors I get instead;

    Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires drupal/title_field_for_manage_display ^1.0, found drupal/title_field_for_manage_display(1.0.0, ..., 1.12.0) but the package is fixed to 2.0.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
  Problem 2
    - drupal/social_auth_google(2.0.0, ..., 2.1.0) require drupal/social_auth ^2.0 -> drupal/social_auth is fixed to 2.x-dev (lock file version) by a partial update but that version is rejected by your minimum-stability. Make sure you list it as an argument for the update command.
    - Root composer.json requires drupal/social_auth_google ^2.0 -> satisfiable by drupal/social_auth_google(2.0.0, 2.1.0).


Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Here’s my composer.json ;

{
"name": "drupal/recommended-project",
"description": "Project template for Drupal 9 projects with a relocated document root",
"type": "project",
"license": "GPL-2.0-or-later",
"homepage": "https://www.drupal.org/project/drupal",
"support": {
    "docs": "https://www.drupal.org/docs/user_guide/en/index.html",
    "chat": "https://www.drupal.org/node/314178"
},
"repositories": (
    {
        "type": "composer",
        "url": "https://packages.drupal.org/8"
    }
),
"require": {
    "composer/installers": "^1.9",
    "drupal/core-composer-scaffold": "^9.1",
    "drupal/core-project-message": "^9.1",
    "drupal/core-recommended": "^9.1",
    "drupal/title_field_for_manage_display": "^1.0"
},
"conflict": {
    "drupal/drupal": "*"
},
"minimum-stability": "stable",
"prefer-stable": true,
"config": {
    "sort-packages": true
},
"extra": {
    "drupal-scaffold": {
        "locations": {
            "web-root": "web/"
        }
    },
    "installer-paths": {
        "web/core": (
            "type:drupal-core"
        ),
        "web/libraries/{$name}": (
            "type:drupal-library"
        ),
        "web/modules/contrib/{$name}": (
            "type:drupal-module"
        ),
        "web/profiles/contrib/{$name}": (
            "type:drupal-profile"
        ),
        "web/themes/contrib/{$name}": (
            "type:drupal-theme"
        ),
        "drush/Commands/contrib/{$name}": (
            "type:drupal-drush"
        ),
        "web/modules/custom/{$name}": (
            "type:drupal-custom-module"
        ),
        "web/profiles/custom/{$name}": (
            "type:drupal-custom-profile"
        ),
        "web/themes/custom/{$name}": (
            "type:drupal-custom-theme"
        )
    },
    "drupal-core-project-message": {
        "include-keys": (
            "homepage",
            "support"
        ),
        "post-create-project-cmd-message": (
            "<bg=blue;fg=white>                                                         </>",
            "<bg=blue;fg=white>  Congratulations, you’ve installed the Drupal codebase  </>",
            "<bg=blue;fg=white>  from the drupal/recommended-project template!          </>",
            "<bg=blue;fg=white>                                                         </>",
            "",
            "<bg=yellow;fg=black>Next steps</>:",
            "  * Install the site: https://www.drupal.org/docs/8/install",
            "  * Read the user guide: https://www.drupal.org/docs/user_guide/en/index.html",
            "  * Get support: https://www.drupal.org/support",
            "  * Get involved with the Drupal community:",
            "      https://www.drupal.org/getting-involved",
            "  * Remove the plugin that prints this message:",
            "      composer remove drupal/core-project-message"
        )
    }
}

}

How can I fix composer?

packages – Get notation rule list so far

One can get list of every variable name so far by

Names("Global`*")

Likewise, is there a code to get list of every user-defined notation rule(using notation package) so far? like

NotaionRuleDefined("Global`*")

In that list, can I distinguish whether a notation rule is effective at present /or not?