boot – MSI H410 + intel 10600kf wont install windows?

I’m getting the windows error “A media driver is missing” when trying to do a very fresh install of windows. The only things I have plugged into the computer are my completely empty but formatted SSD, and my installation media, as well as a few peripherals.
Solutions I have tried:
Fresh .iso for the windows install
using the included CD (Copied over onto a usb first) during windows setup (Still missing drivers)
That weird trick where you switch the USB port you use halfway through.
Trying to find drivers online. I am not sure what drivers i even need but i got the ones for my GTX 970??
If anyone has ANY ideas I am at my witts end. Please Help.

encryption – Clean LineageOS 17.1 install and empty device – can’t work out how to mount data partition in TWRP?

I’m installing LineageOS 17.1 on my new phone. It works fine, but I can’t get to data in TWRP.

As usual, to install, I wipe everything, drop into TWRP, format (not just wipe) data, wipe cache/davlik/system, and flash the LineageOS installer file. When the system starts first time, it gives a message “encrypting data”, which doesn’t have a “skip” option.

When I drop back into TWRP it asks for a decryption password to access data, but I don’t have one because I haven’t entered one in the first place.

How do I get LOS to not encrypt data, or alternatively, what decryption password should I use in TWRP?

Note: this isn’t a duplicate question. Other questions about decrypting data involve corrupt data or system issues that prevent data being accessed because of encryption, or trying to recover files from data. In my case, it’s a clean install with no prior data content, but I can’t figure how to access data in TWRP because it seem to encrypt it automatically but there’s no hint what key to enter in TWRP.

Newbie:- Just bought MacMini M1, not happy with BigSur can I install Catalina and if so how?

Just bought a MacMini M1, not happy with BigSur is it possible to remove BigSur and install Catalina and if so how?

laptop – Will I be able to install Ubuntu 20.04 on a just-purchased HP Pavilion with the Intel Core i5 1035G1?

I’ve purchased the HP Pavilion 15-cs3006nv Laptop with a Core i5 1035G1.
(I expect it to be delivered on Jan 29)
I am wondering if the latest .iso of Ubuntu 20.04 LTS has the latest kernel version, to rest assure that I will be able to install Ubuntu on my machine, or if the initial .iso release is going to do the job anyway!
If this is not the case, what should I do to install Ubuntu on this machine?

apt – Can no longer install anything or upgrade on lubuntu

The lubuntu version I have is:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.10
Release:        19.10
Codename:       eoan

When I try to install anything, I get these errors about sources:

E: The repository 'http://security.ubuntu.com/ubuntu eoan-security Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Answers about this in other threads say to go into Software Sources and uncheck basically everything, and then only enable main. However, when I enable just main and close, it says:

Your local copy of the software catalog is out of date. A new copy will be downloaded.

So I hit Reload and it says

pk-client-error-quark: E: The repository 'http://dk.archive.ubuntu.com/ubuntu eoan Release' does not have a Release file.
W: Updating from such a repository can't be done securely, and is therefore disabled by default.
W: See apt-secure(8) manpage for repository creation and user configuration details.
 (319)

So now I am stuck. How can I install anything now?


I understand that 19.10 is no longer supported. I would be happy to upgrade. However, I cannot seem to upgrade either. When I follow this guide on upgrading, it says to run

sudo apt update && sudo apt full-upgrade -y

However, this encounters the same error about sources as above!

How can I make any progress here?

How to install npm dependencies?

I installed npm:
apt install npm

Then ran npm install in the easyappointments folder and got an error:

npm WARN trumbowyg@2.21.0 requires a peer of jQuery@>=1.8 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fullcalendar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fullcalendar/node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

Also I used npm install jQuery:

npm WARN deprecated jQuery@1.7.4: This is deprecated. Please use 'jquery' (all lowercase).
npm WARN trumbowyg@2.21.0 requires a peer of jQuery@>=1.8 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fullcalendar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fullcalendar/node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

+ jQuery@1.7.4
added 1 package from 1 contributor and audited 583 packages in 9.63s

32 packages are looking for funding
  run `npm fund` for details

found 5 vulnerabilities (3 low, 2 high)
  run `npm audit fix` to fix them, or `npm audit` for details

How do I fix this?

terminal – Unable to install git using homebrew

I am trying to install git using homebrew:

brew install git

Terminal reads:

==> Searching for similarly named formulae… Error: No similarly named formulae found. Error: No available formula or cask with the
name “git”.
==> Searching for a previously deleted formula (in the last month)… Error: No previously deleted formula found.
==> Searching taps on GitHub… Error: No formulae found in taps.

If I input brew doctor, I get the following:

Warning: Suspicious https://github.com/Homebrew/homebrew-core git
origin remote found. The current git origin is:
https://github.com/Homebrew/brew With a non-standard origin, Homebrew
won’t update properly. You can solve this by setting the origin
remote: git -C
“/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core” remote
set-url origin https://github.com/Homebrew/homebrew-core

However, if i do git -C "/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core" remote set-url origin https://github.com/Homebrew/homebrew-core, nothing changes and I get the same output with brew doctor

command line tools is installed:

xcode-select --install

xcode-select: error: command line tools are already installed, use
“Software Update” to install updates

I have tried reinstalling brew, brew update and brew cleanup

Any help would be greatly appreciated.

My mac is in internet recovery, it is a 2017 MBA. The install always fails

The error in the log is: Commerce:DownloadManifest: Failed to write to the manifest at /var/folders/zz/<some random letters>/C/com.apple.appstore/manifest.plist

How to install PHP 7.4.3 on CentOS 8?

I need to upgrade to PHP 7.4.3 (from 7.4.14), and I have somehow managed to make no progress after many, many hours.
*Needed for MediaWiki, Roundcube and PostfixAdmin.

  1. Do I have to compile from source to get 7.4.3, or is there an easier way?
  2. If yes to the above, how do I fix the bugs below?

Errors

openssl and imap are clearly giving me trouble (opcache was much worse until I just disabled it)

=====================================================================
TIME END 2021-01-19 04:58:21

=====================================================================
TEST RESULT SUMMARY
---------------------------------------------------------------------
Exts skipped    :   18
Exts tested     :   55
---------------------------------------------------------------------

Number of tests : 15674             12815
Tests skipped   : 2859 ( 18.2%) --------
Tests warned    :    0 (  0.0%) (  0.0%)
Tests failed    :   17 (  0.1%) (  0.1%)
Expected fail   :   35 (  0.2%) (  0.3%)
Tests passed    : 12763 ( 81.4%) ( 99.6%)
---------------------------------------------------------------------
Time taken      : 1099 seconds
=====================================================================

=====================================================================
EXPECTED FAILED TEST SUMMARY
---------------------------------------------------------------------
Test open_basedir configuration (tests/security/open_basedir_linkinfo.phpt)  XFAIL REASON: BUG: open_basedir cannot delete symlink to prohibited file. See also
bugs 48111 and 52176.
Inconsistencies when accessing protected members (Zend/tests/access_modifiers_008.phpt)  XFAIL REASON: Discussion: http://marc.info/?l=php-internals&m=120221184420957&w=2
Inconsistencies when accessing protected members - 2 (Zend/tests/access_modifiers_009.phpt)  XFAIL REASON: Discussion: http://marc.info/?l=php-internals&m=120221184420957&w=2
Bug #48770 (call_user_func_array() fails to call parent from inheriting class) (Zend/tests/bug48770.phpt)  XFAIL REASON: See Bug #48770
Bug #48770 (call_user_func_array() fails to call parent from inheriting class) (Zend/tests/bug48770_2.phpt)  XFAIL REASON: See Bug #48770
Bug #48770 (call_user_func_array() fails to call parent from inheriting class) (Zend/tests/bug48770_3.phpt)  XFAIL REASON: See Bug #48770
Initial value of static var in method depends on the include time of the class definition (Zend/tests/method_static_var.phpt)  XFAIL REASON: Maybe not a bug
DateTime::add() -- fall type2 type3 (ext/date/tests/DateTime_add-fall-type2-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::add() -- fall type3 type2 (ext/date/tests/DateTime_add-fall-type3-type2.phpt)  XFAIL REASON: Various bugs exist
DateTime::add() -- fall type3 type3 (ext/date/tests/DateTime_add-fall-type3-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::add() -- spring type2 type3 (ext/date/tests/DateTime_add-spring-type2-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::add() -- spring type3 type2 (ext/date/tests/DateTime_add-spring-type3-type2.phpt)  XFAIL REASON: Various bugs exist
DateTime::add() -- spring type3 type3 (ext/date/tests/DateTime_add-spring-type3-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::diff() -- fall type2 type3 (ext/date/tests/DateTime_diff-fall-type2-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::diff() -- fall type3 type2 (ext/date/tests/DateTime_diff-fall-type3-type2.phpt)  XFAIL REASON: Various bugs exist
DateTime::diff() -- fall type3 type3 (ext/date/tests/DateTime_diff-fall-type3-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::diff() -- spring type2 type3 (ext/date/tests/DateTime_diff-spring-type2-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::diff() -- spring type3 type2 (ext/date/tests/DateTime_diff-spring-type3-type2.phpt)  XFAIL REASON: Various bugs exist
DateTime::diff() -- spring type3 type3 (ext/date/tests/DateTime_diff-spring-type3-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::sub() -- fall type2 type3 (ext/date/tests/DateTime_sub-fall-type2-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::sub() -- fall type3 type2 (ext/date/tests/DateTime_sub-fall-type3-type2.phpt)  XFAIL REASON: Various bugs exist
DateTime::sub() -- fall type3 type3 (ext/date/tests/DateTime_sub-fall-type3-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::sub() -- spring type2 type3 (ext/date/tests/DateTime_sub-spring-type2-type3.phpt)  XFAIL REASON: Various bugs exist
DateTime::sub() -- spring type3 type2 (ext/date/tests/DateTime_sub-spring-type3-type2.phpt)  XFAIL REASON: Various bugs exist
DateTime::sub() -- spring type3 type3 (ext/date/tests/DateTime_sub-spring-type3-type3.phpt)  XFAIL REASON: Various bugs exist
Bug #52480 (Incorrect difference using DateInterval) (ext/date/tests/bug52480.phpt)  XFAIL REASON: See https://bugs.php.net/bug.php?id=52480
RFC: DateTime and Daylight Saving Time Transitions (zone type 3, bd2) (ext/date/tests/rfc-datetime_and_daylight_saving_time-type3-bd2.phpt)  XFAIL REASON: Still not quite right
RFC: DateTime and Daylight Saving Time Transitions (zone type 3, fs) (ext/date/tests/rfc-datetime_and_daylight_saving_time-type3-fs.phpt)  XFAIL REASON: Still not quite right
Bug #42718 (unsafe_raw filter not applied when configured as default filter) (ext/filter/tests/bug42718.phpt)  XFAIL REASON: FILTER_UNSAFE_RAW not applied when configured as default filter, even with flags
Bug #67296 (filter_input doesn't validate variables) (ext/filter/tests/bug49184.phpt)  XFAIL REASON: See Bug #49184
Bug #67167: filter_var(null,FILTER_VALIDATE_BOOLEAN,FILTER_NULL_ON_FAILURE) returns null (ext/filter/tests/bug67167.02.phpt)  XFAIL REASON: Requires php_zval_filter to not use convert_to_string for all filters.
via (ext/pdo_sqlite/tests/common.phpt)
        SQLite PDO Common: PDOStatement::getColumnMeta (ext/pdo_sqlite/tests/pdo_022.phpt)  XFAIL REASON: This feature is not yet finalized, no test makes sense
Phar: bug #69958: Segfault in Phar::convertToData on invalid file (ext/phar/tests/bug69958.phpt)  XFAIL REASON: Still has memory leaks, see https://bugs.php.net/bug.php?id=70005
updateTimestamp never called when session data is empty (ext/session/tests/bug71162.phpt)  XFAIL REASON: Current session module is designed to write empty session always. In addition, current session module only supports SessionHandlerInterface only from PHP 7.0.
Bug #73529 session_decode() silently fails on wrong input (ext/session/tests/bug73529.phpt)  XFAIL REASON: session_decode() does not return proper status.
=====================================================================

=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #77020 (null pointer dereference in imap_mail) (ext/imap/tests/bug77020.phpt)
Bug #65729: CN_match gives false positive when wildcard is used (ext/openssl/tests/bug65729.phpt)
Bug #68265: SAN match fails with trailing DNS dot (ext/openssl/tests/bug68265.phpt)
Bug #68879: Match IP address fields in subjectAltName checks (ext/openssl/tests/bug68879.phpt)
Bug #68920: peer_fingerprint input checks should be strict (ext/openssl/tests/bug68920.phpt)
Bug #69215: Crypto servers should send client CA list (ext/openssl/tests/bug69215.phpt)
Peer verification matches SAN names (ext/openssl/tests/san_peer_matching.phpt)
security_level setting to prohibit cert (ext/openssl/tests/stream_security_level.phpt)
Specific crypto method for ssl:// transports. (ext/openssl/tests/streams_crypto_method.phpt)
tls stream wrapper with min version 1.0 and max version 1.1 (ext/openssl/tests/tls_min_v1.0_max_v1.1_wrapper.phpt)
tls stream wrapper (ext/openssl/tests/tls_wrapper.phpt)
tls stream wrapper when TLS 1.3 available (ext/openssl/tests/tls_wrapper_with_tls_v1.3.phpt)
tlsv1.0 stream wrapper (ext/openssl/tests/tlsv1.0_wrapper.phpt)
tlsv1.1 stream wrapper (ext/openssl/tests/tlsv1.1_wrapper.phpt)
tlsv1.2 stream wrapper (ext/openssl/tests/tlsv1.2_wrapper.phpt)
tlsv1.3 stream wrapper (ext/openssl/tests/tlsv1.3_wrapper.phpt)
Multicast support: IPv6 receive options (ext/sockets/tests/mcast_ipv6_recv.phpt)
=====================================================================

Attempts

Basic summary; not including countless rabbitholes, detours and revertions after unsuccessful attempts that modified the system.

  1. Tried dnf and remi.

    Could not specify **7.4.3**, just **7.4.14**.  Have PHP 72, 73 74, and 80, with 7.4.14 currently enabled.
    
  2. Compiled + installed PHP 8.0

    Mistake (did not know that '>= **7.4.3**' instructions evidently does not include >= 8.0)
    
    Note: naturally, because none of the programs could run on this version, it of course compiled/installed seamlessly, with not even one error (:
    
  3. New solution: compile 7.4.3 from source

    i. Got php 7.4.3 .tar from official PHP site; extracted it and did ./configure ...

    ii. Run ./configure ..., first error(s):

    Wrong version for PHP extensions
    
    Solution: almost all of the non-base PHP extensions needed their `-devel` version installed.
    

    iii. ./configure ... works now, so run make clean, make && make test

    make test errors: similar to the bugs below (under ‘Errors’), but with at least twice as many because opcache

    Solution: Added `--disable-opcache --disable-opcache-file` to `./configure ...`
    

    iv. run make clean, make && make test as sudo again

    Where I am now.  Already have openssl-devel, and cannot find imap-devel or anything similar.
    

make procedure

To run ./configure without errors, had to install all the following with yum (excepting oniguruma, oniguruma-devel from DNF):

libcurl-devel, bzip2-devel, libpng-devel, libjpeg-devel, freetype-devel, libc-client-devel, libicu-devel, oniguruma, oniguruma-devel, postgresqlm, postgresql-devel, readline-devel, libsodium-devel, libxslt-devel, zip-devel, libsodium-devel, libxslt-devel, zip-devel

First successful:

% Used --disable-opcache --disable-opcache-file to get rid of opcache errors, since it is optional
sudo ./configure --prefix=/opt/php-7.4 --with-pdo-pgsql --with-zlib-dir --enable-ctype --with-freetype --enable-mbstring --enable-soap --enable-calendar --with-curl --with-zlib --enable-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --enable-exif --enable-bcmath --with-mhash --with-zip --with-pdo-mysql --with-mysqli --with-mysql-sock=/var/lib/mysql/mysql.sock --with-jpeg --with-openssl --with-fpm-user=nginx --with-fpm-group=nginx --with-libdir=lib64 --enable-ftp --with-imap --with-imap-ssl --with-kerberos --with-gettext --with-xmlrpc --with-xsl --disable-opcache --enable-intl --with-pear --enable-shmop --with-sodium --with-readline --enable-fpm

System Details

VPS, CentOS 8. Used as web and email server, with node.js for everything that is not the 3 PHP programs above.

Database: mariadb

Mail: postfix, dovecot, opendkim, opendmarc, spamassassin, clamav

Web: nginx

other:: php-fpm, MEAN stack, some LEMP (MediaWiki, Roundcube and PostfixAdmin)

applications – Samsung Galaxy M11 and Samsung Galaxy M01s not able to install 64bit apps from google play store even while having 64bit chipsets

Samsung Galaxy M11 has a Qualcomm SDM450 Snapdragon 450 chipset while the Samsung Galaxy M01s has a Mediatek MT6762 Helio P22 chipset. Going to their websites, on Qualcomm and Mediatek respectively, shows that they both support 64bit. However as mentioned in the title, the two phones are unable to install 64bit apps from the Google Play Store. I am suspecting that the reason for this is because their OSs might be 32bit. (I can’t check personally because someone else has the phones and I am trying to solve a problem for them.) If that is the case, is it wise to flash a 64bit OS to the phones to be able to run 64bit apps?
Below are the links to the chipset specs on their respective websites:

https://www.qualcomm.com/products/snapdragon-450-mobile-platform

https://www.mediatek.com/products/smartphones/mediatek-helio-p22