Error al instalar autenticación básica Jetstream en Laravel 8

Estoy tratando de hacer una instalación fresca de Laravel 8 con la autenticación básica.
Trabajo hace bastante con Laravel, pero este error es nuevo para mi. Laravel básico lo instala bien pero al momento de instalar Jetstream y correr “npm install && npm run dev”, tira el bendito error.

Ya intenté con npm rebuild y todo lo que es borrar node_modules y hacer npm install, y nada.
Exactamente no comprendo que sucede. El servidor es Centos7. Agradeceré ayuda al problema ya que estoy detenido con este tema hace horas.

    cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js

    /home/miproyecto/public_html/proyecto/proyectolar/node_modules/cross-env/src/index.js:23
        )
        ^

    SyntaxError: Unexpected token )
        at createScript (vm.js:56:10)
        at Object.runInThisContext (vm.js:97:10)
        at Module._compile (module.js:549:28)
        at Object.Module._extensions..js (module.js:586:10)
        at Module.load (module.js:494:32)
        at tryModuleLoad (module.js:453:12)
        at Function.Module._load (module.js:445:3)
        at Module.require (module.js:504:17)
        at require (internal/module.js:20:19)
        at Object.<anonymous> (/home/miproyecto/public_html/proyecto/proyectolar/node_modules/cross-env/src/bin/cross-env.js:3:18)

    npm ERR! Linux 3.10.0-1160.6.1.el7.x86_64
    npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "run" "development"
    npm ERR! node v6.17.1
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! @ development: `cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the @ development script 'cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the  package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs 
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls 
    npm ERR! There is likely additional logging output above.

    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/miproyecto/public_html/proyecto/proyectolar/npm-debug.log

    npm ERR! Linux 3.10.0-1160.6.1.el7.x86_64
    npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "run" "dev"
    npm ERR! node v6.17.1
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! @ dev: `npm run development`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the @ dev script 'npm run development'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the  package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     npm run development
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs 
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls 
    npm ERR! There is likely additional logging output above.

    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/miproyecto/public_html/proyecto/proyectolar/npm-debug.log

Error al instalar un paquete nuget visual studio 2015

Cómo puedo solucionar este error? lo mismo me sucedió en visual studio 2012, 2013 y ahora en el 2015.

Uso netframework 4.8.introducir la descripción de la imagen aquí

Como instalar pip do python 3 no Kali Linux?

Estou precisando instalar o pip do python 3 no Kali Linux, mas está dando um erro que não sei como resolver:

The following packages have unmet dependencies:
libc6-dev : Breaks: libgcc-9-dev (< 9.3.0-5~) but 9.2.1-19 is to be installed
linux-headers-5.3.0-kali2-amd64 : Depends: linux-compiler-gcc-9-x86 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Já procurei como resolver mas não achei nada.
Se puderem me ajudar, por favor. Desde já agradeço.

Não consigo instalar nenhum pacote relacionado a python no meu computador

Não consigo instalar nenhum pacote do python na minha máquina, desinstalei e reinstalei o python do meu computador, já tentei instalar pelo PowerShell e CMD alternando entre execução comum e como administrador na hora da instalação e não fez diferença alguma, tentei instalar o pacote ‘pygame’ e o pacote ‘matplotlib’ sem sucesso, aliás com todos os pacotes que tentei deu o mesmo erro.

ao executar o comando ‘pip install pygame’ exibe a seguinte mensagem:

    ERROR: Command errored out with exit status 1:
     command: 'c:usersmazieriappdatalocalprogramspythonpython39python.exe' -c 'import sys, setuptools, tokenize; sys.argv(0) = '"'"'C:\Users\Mazieri\AppData\Local\Temp\pip-install-9yiln3pv\pygame\setup.py'"'"'; __file__='"'"'C:\Users\Mazieri\AppData\Local\Temp\pip-install-9yiln3pv\pygame\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:UsersMazieriAppDataLocalTemppip-pip-egg-info-pv5icshi'
         cwd: C:UsersMazieriAppDataLocalTemppip-install-9yiln3pvpygame
    Complete output (17 lines):


    WARNING, No "Setup" File Exists, Running "buildconfig/config.py"
    Using WINDOWS configuration...


    Download prebuilts to "prebuilt_downloads" and copy to "./prebuilt-x64"? (Y/n)Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:UsersMazieriAppDataLocalTemppip-install-9yiln3pvpygamesetup.py", line 194, in <module>
        buildconfig.config.main(AUTO_CONFIG)
      File "C:UsersMazieriAppDataLocalTemppip-install-9yiln3pvpygamebuildconfigconfig.py", line 210, in main
        deps = CFG.main(**kwds)
      File "C:UsersMazieriAppDataLocalTemppip-install-9yiln3pvpygamebuildconfigconfig_win.py", line 576, in main
        and download_win_prebuilt.ask(**download_kwargs):
      File "C:UsersMazieriAppDataLocalTemppip-install-9yiln3pvpygamebuildconfigdownload_win_prebuilt.py", line 302, in ask
        reply = raw_input(
    EOFError: EOF when reading a line
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. 

problema para instalar Jupyter – Stack Overflow en español

he intentado instalar Jupyter con pip y despues de avanzar la instalacion desde un momento me da error.Como solución me indicaron que instale visual studio y se resolveria pero no fue asi. Para que pueda ver lo que me dice la laptop, pego una imagen de lo que me indica:
https://i.stack.imgur.com/ZMgTC.png
introducir la descripción de la imagen aquí

windows10 – como instalar modulos math en vs code para trabjar en python?

import math
tengo un código que empieza con esta función como hago en vs code para trabajar con las librerias de python, aun sabiendo que el comando pip –upgrade pip no me lo acepta, y por ende me sale este error ModuleNotFoundError: No module named ‘function’, alguien podria ayudarme?

visual studio code – Erro ao instalar o minGW

Estou tentando baixar o minGW para executar C no vscode, mas aparece os seguintes erros:

mingw-get: *** ERROR *** unpack: required archive file is not available

mingw-get: *** ERROR *** unpack: aborted due to previous download failure

mingw-get: *** ERROR *** setup: unable to continue

Não faço ideia do que seja, procurei soluções no google e acabei indo atras do winGWx84, que também não consegui instalar. Preciso de um help.

python – Error al instalar dependencias en pipenv

Espero no ser tan obvio pero soy novato. Estoy intentando instalar scipy en pipenv pero no me permite. una de mis ideas es que como ya tengo instalado previamente pandas (e implícitamente numpy) no me permite, ya que de acuerdo a la información scipy los tiene como paquetes integrados.

Espero alguién me pueda ayudar.

Cómo entregar el parámetro spring.config.location a WinSW al instalar un JAR SpringBoot como servicio Windows?

Estoy intentando usar WinSW para instalar un JAR de Spring Boot como servicio de Windows. Logro que funcione si en los argumentos le doy sólo el nombre del JAR.

<service>
    <id>testSB/id>
    <name>testSB</name>
    <description>This service runs a spring boot JAR as service.</description>
    <executable>java</executable>
    <startmode>Automatic</startmode>
    <delayedAutoStart>true</delayedAutoStart>
    <onfailure action="restart" delay="10 sec"/>
    <onfailure action="restart" delay="20 sec"/>
    <onfailure action="none"/>
    <resetfailure>1 hour</resetfailure>
    <arguments>-jar "myjar-1.0.0.jar" </arguments>
    <log mode="roll-by-size-time">
      <sizeThreshold>20480</sizeThreshold>
      <pattern>yyyyMMdd</pattern>
      <autoRollAtTime>00:30:00</autoRollAtTime>
      <zipOlderThanNumDays>5</zipOlderThanNumDays>
    </log>
    <logpath>%BASE%/logs</logpath>
</service>

FUnciona y veo la página principal del servicio.

Pero, si le añado –spring.config.location=application.yml para que use ese archivo externo de configuración, el servicio no arranca.

<service>
    <id>testSB/id>
    <name>testSB</name>
    <description>This service runs a spring boot JAR as service.</description>
    <executable>java</executable>
    <startmode>Automatic</startmode>
    <delayedAutoStart>true</delayedAutoStart>
    <onfailure action="restart" delay="10 sec"/>
    <onfailure action="restart" delay="20 sec"/>
    <onfailure action="none"/>
    <resetfailure>1 hour</resetfailure>
    <arguments>-jar "myjar-1.0.0.jar" --spring.config.location=./application.yml</arguments>
    <log mode="roll-by-size-time">
      <sizeThreshold>20480</sizeThreshold>
      <pattern>yyyyMMdd</pattern>
      <autoRollAtTime>00:30:00</autoRollAtTime>
      <zipOlderThanNumDays>5</zipOlderThanNumDays>
    </log>
    <logpath>%BASE%/logs</logpath>
</service>

Ya probé con ruta relativa ./app.yml, usando la variable %BASE%: %BASE%/app.yml, con la ruta absoluta: C:pathtoapp.yml. Siempre falla y los logs sólo dicen:

2020-09-21 16:57:25,626 DEBUG - Completed. Exit code is 0
2020-09-21 16:57:30,560 DEBUG - Starting WinSW in console mode
2020-09-21 16:57:30,930 DEBUG - User requested the status of the process with id 'testSB'
2020-09-21 16:57:30,932 DEBUG - Completed. Exit code is 0
2020-09-21 16:57:35,363 DEBUG - Starting WinSW in service mode
2020-09-21 16:57:35,380 INFO  - Starting java -jar "myjar-1.0.0.jar" --spring.config.location=C:pathtoapplication.yml
2020-09-21 16:57:35,395 DEBUG - Completed. Exit code is 0

El Visor de Eventos de Windows muestra un error cada vez que lo intento arrancar, que dice:

Service cannot be started. System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
   at WinSW.Util.ProcessHelper.StartProcessAndCallbackForExit(Process processToStart, String executable, String arguments, Dictionary`2 envVars, String workingDirectory, Nullable`1 priority, ProcessCompletionCallback callback, Boolean redirectStdin, LogHandler logHandler, Boolean hideWindow)
   at WinSW.WrapperService.StartProcess(Process processToStart, String arguments, String executable, LogHandler logHandler, Boolean redirectStdin)
   at WinSW.WrapperService.OnStart(String() args)
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

Alguien sabe cómo arranco ese JAR como servicio diciéndole que use ese yml?? Gracias.

Instalar extensões do Laravel – Stack Overflow em Português

Estou criando um projeto Laravel pela primeira vez no meu Ubuntu, mas não tenho experiência com ele, quando rodei o comando abaixo o projeto aparentemente foi criado corretamente, mas deu essa mensagem como se estivesse faltando algumas extensões, eu instalei a primeira que ele reclamou mas parece que cada vez precisa de outra. Isso é realmente necessário e se for tem como instalar tudo de uma só vez?

➜ docker composer create-project laravel/laravel Creating a
“laravel/laravel” project at “./laravel” Installing laravel/laravel
(v8.0.1)

  • Installing laravel/laravel (v8.0.1): Loading from cache Created project in /media/rafael/DADOS/DEV/Cursos/Full Cycle/docker/laravel

@php -r “file_exists(‘.env’) || copy(‘.env.example’, ‘.env’);” Loading composer repositories with package information Updating
dependencies (including require-dev) Your requirements could not be
resolved to an installable set of packages.

Problem 1
– phpunit/phpunit 9.4.x-dev requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.x-dev requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.9 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.8 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.7 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.6 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.5 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.4 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.2 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.10 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.1 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– phpunit/phpunit 9.3.0 requires ext-dom * -> the requested PHP extension dom is missing from your system.
– Installation request for phpunit/phpunit ^9.3 -> satisfiable by phpunit/phpunit(9.3.0, 9.3.1, 9.3.10, 9.3.2, 9.3.3, 9.3.4, 9.3.5,
9.3.6, 9.3.7, 9.3.8, 9.3.9, 9.3.x-dev, 9.4.x-dev).

To enable extensions, verify that they are enabled in your .ini
files:
– /etc/php/7.4/cli/php.ini
– /etc/php/7.4/cli/conf.d/10-opcache.ini
– /etc/php/7.4/cli/conf.d/10-pdo.ini
– /etc/php/7.4/cli/conf.d/20-calendar.ini
– /etc/php/7.4/cli/conf.d/20-ctype.ini
– /etc/php/7.4/cli/conf.d/20-exif.ini
– /etc/php/7.4/cli/conf.d/20-ffi.ini
– /etc/php/7.4/cli/conf.d/20-fileinfo.ini
– /etc/php/7.4/cli/conf.d/20-ftp.ini
– /etc/php/7.4/cli/conf.d/20-gettext.ini
– /etc/php/7.4/cli/conf.d/20-iconv.ini
– /etc/php/7.4/cli/conf.d/20-json.ini
– /etc/php/7.4/cli/conf.d/20-mbstring.ini
– /etc/php/7.4/cli/conf.d/20-phar.ini
– /etc/php/7.4/cli/conf.d/20-posix.ini
– /etc/php/7.4/cli/conf.d/20-readline.ini
– /etc/php/7.4/cli/conf.d/20-shmop.ini
– /etc/php/7.4/cli/conf.d/20-sockets.ini
– /etc/php/7.4/cli/conf.d/20-sysvmsg.ini
– /etc/php/7.4/cli/conf.d/20-sysvsem.ini
– /etc/php/7.4/cli/conf.d/20-sysvshm.ini
– /etc/php/7.4/cli/conf.d/20-tokenizer.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.