hang – Macbook pro 13″ early 2015 freezes and shut down

Macbook pro 13″ early 2015 freezing after login.

Tried solutions

  • Format and Reinstall OS
  • Apple Hardware diagnose
  • SMC and PRAM reset
  • Open in safe mode
  • Stopped using google chrome
  • Disabled Firevault

However, sometimes after trying for 2-3 days it suddenly starts working then again a few days later it back to freeze and shut down.

System Specs

  • 8 GB ram
  • 512 SSD
  • 2.9 GHz
  • Dual core i5

firefox – System just freezes, everything just stops including mouse and even the wifi gets disconnected from mobile hotspot

My system was working fine but after the changes in past two days I started getting this problem.

The Changes I made: I replaced my old HDD with a new SSD two days ago and installed Linux on it. And yesterday there was a kernel update in the update manager.

How problem started occurring: After the update and 3 or 4 reboots, when I was installing wine through terminal system freezed and I had to do hard reboot, then again when wine was installed I was installing Docky from 18.04’s repository it again freezed.

The third and fourth time it freezed right after booting up when I launched firefox.

After some googled suggestions I did a smartctl. So can you tell me weather it’s a system error or the SSD’s broken.

Here are smartctl‘s results in the given : link

mojave – Macbook pro 15 inch 2017 freezes until hard reboot

My 15 inch MacBook pro running Mojave (10.14.6) recently started freezing randomly staying completely unresponsive. I use an external monitor and all I see is the screensaver frozen, when disconnected the MacBook’s screen remains black.

I tried resetting the SMC, PRAM, and VRAM but it happened again. The problem goes away momentarily when I hard reset the computer. I checked and there’s no crash reports to be found after the reboot. I checked the SSD with DiskUtility and no problem was found.

I have a copy of system.log and I know the approximate time of today’s freeze, but I don’t know how to read the log file, I can copy the log file if necessary.

What else can I do to diagnostic my computer?? Or does anyone know what could be happening?

Thanks.

usb – Ubuntu freezes when connecting external audio interface

AskUbuntu! Newbie here.

When I connect either my Scarlette 2i2, or my headset USB
interface, at first nothing happens. When I either suspend or log out,
my mouse freezes. Sometimes the keyboard as well.
I’ve had to restart by using the reset button on my case.
Could this be a problem with my mobos USB controller?
Tried both the front panel USB ports and the
ones on the back, no luck.

I am experiencing very high Power and CPU usage and I my computer sometimes freezes when it hits 100%

This problem cropped up a week ago and is worse when I am running my Tradestation trading app. I have been through troubleshooting with a number of different tech. I have re-installed windows and I have reinstalled the tradestation app. I have been over all the suggested power settings and some things helped a little it seems the problem is still here. I tested my power supply with a volt meter and all terminals put out exactly what they should.
I am running windows 10 with an AMD Phenom II X4 Processor with 8 GB of Ram
This system ran great up until a week ago, I made no changes to anything prior to having this issue.
The Microsoft tech has cleaned up files and all the regular speed up you PC things. We also uninstalled the Macafee antivirus to see if it was causing an issue
The Tech at Tradestation suggested my computer was to old/slow not enough cores etc. but I call BS as I am able to run tradestation on a laptop that has a 2 core processor. I have run the application on this computer for a long time this is a new problem I don’t think it is a hardware issue. Any and all help would be greatly appreciated.

routeros – Mikrotik. Router OS. IPTV image freezes after 3-5 minutes since channel switching

In order to unfreeze I have to switch channel. Here’s the config:

add admin-mac=48:33:5A:3D:4E:84 auto-mac=no comment=defconf igmp-snooping=yes 
    name=bridge
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 
    password=abcxyz123 use-peer-dns=yes user=abcxyz123
/interface wireless
set ( find default-name=wlan1 ) band=2ghz-b/g/n channel-width=20/40mhz-XX 
    distance=indoors frequency=auto installation=indoor mode=ap-bridge ssid=
    MikroTik-3D8E88 wireless-protocol=802.11
set ( find default-name=wlan2 ) band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX 
    disabled=no distance=indoors frequency=auto installation=indoor mode=
    ap-bridge ssid=CosmicFruits wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set ( find default=yes ) authentication-types=wpa2-psk mode=dynamic-keys 
    supplicant-identity=MikroTik wpa-pre-shared-key=ABCXYZ123 
    wpa2-pre-shared-key=ABCXYZ123
/ip hotspot profile
set ( find default=yes ) html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge filter
add action=drop chain=output out-interface=wlan2 packet-type=multicast
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=
    192.168.88.0
add address=1.0.0.1/30 interface=ether1 network=1.0.0.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan type=A
/ip firewall filter
add action=accept chain=input comment=
    "defconf: accept established,related,untracked" connection-state=
    established,related,untracked
add action=accept chain=forward comment="ALLOW IGMP" in-interface=ether1 
    protocol=udp
add action=accept chain=forward in-interface=ether1 protocol=igmp
add action=drop chain=input comment="defconf: drop invalid" connection-state=
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" 
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" 
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" 
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" 
    connection-state=established,related
add action=accept chain=forward comment=
    "defconf: accept established,related, untracked" connection-state=
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=
    invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" 
    connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=
    out,none out-interface-list=WAN
/ipv6 firewall address-list
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
add address=::224.0.0.0/100 comment="defconf: other" list=bad_ipv6
add address=::127.0.0.0/104 comment="defconf: other" list=bad_ipv6
add address=::/104 comment="defconf: other" list=bad_ipv6
add address=::255.0.0.0/104 comment="defconf: other" list=bad_ipv6
/ipv6 firewall filter
add action=accept chain=input comment=
    "defconf: accept established,related,untracked" connection-state=
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=
    invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" port=
    33434-33534 protocol=udp
add action=accept chain=input comment=
    "defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=
    udp src-address=fe80::/10
add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 
    protocol=udp
add action=accept chain=input comment="defconf: accept ipsec AH" protocol=
    ipsec-ah
add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=
    ipsec-esp
add action=accept chain=input comment=
    "defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment=
    "defconf: drop everything else not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment=
    "defconf: accept established,related,untracked" connection-state=
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=
    invalid
add action=drop chain=forward comment="defconf: drop packets with bad src ipv6" 
    src-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: drop packets with bad dst ipv6" 
    dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" 
    hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=
    icmpv6
add action=accept chain=forward comment="defconf: accept HIP" protocol=139
add action=accept chain=forward comment="defconf: accept IKE" dst-port=500,4500 
    protocol=udp
add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=
    ipsec-ah
add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=
    ipsec-esp
add action=accept chain=forward comment=
    "defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=forward comment=
    "defconf: drop everything else not coming from LAN" in-interface-list=!LAN
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add
/system clock
set time-zone-name=Asia/Dushanbe
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

And no logs are appearing after freezing/unfreezing.

New install of 20.04 on older hardware freezes regularly

I have a new server running Ubuntu 20.04. It freezes about once a day to every other day. Here’s what I have:

ASUS Motherboard with Ryzen 7 (Ran fine for a year with Windows 10)
To build this system, I added new NVME SSD for the system, 16GB of DDR4 RAM, power supply
The BIOS is set up with all defaults (no overclocking of CPU or RAM)
First freeze in the first week of operation
The freeze characteristics:

Desktop frozen, mouse sometimes is responsive
Keyboard unresponsive
SSH sessions in progress are unresponsive, new SSH sessions timeout
Ctl-Alt-Del does nothing
Alt-SysReq REISUB does nothing
For two of the recent hangs, I have left a system monitor running on the desktop with 1 sec update rate. Pictures taken after the freeze are attached.
What I’ve done to troubleshoot (after using hardware reset to recover):

Looked in kern.log and found nothing useful about the subsequent boot. Not even a file system repair
Looked in syslog. The frozen screen shows me the time of the freeze and the syslog file has hundreds of “^@” characters in it (looking with vi) between the last normal-looking entry and the reboot. The section of the file outside of vi looks like:
Aug 15 11:49:10 automation-server influxd(1218): (httpd) 127.0.0.1 – root (15/Aug/2020:11:49:10 -0500) “POST /write?db=homeassistant HTTP/1.1” 204 0 “-” “python-requests/2.24.0” 3dae
3229-df17-11ea-92bf-88d7f6c6331b 3568
Aug 15 11:49:12 automation-server influxd(1218): (httpd) 127.0.0.1 – root (15/Aug/2020:11:49:12 -0500) “POST /write?db=homeassistant HTTP/1.1” 204 0 “-” “python-requests/2.24.0” 3f05
c1cd-df17-11ea-92c0-88d7f6c6331b 2749
Aug 15 11:49:14 automation-server influxd(1218): (httpd) 127.0.0.1 – root (15/Aug/2020:11:49:14 -0500) “POST /write?db=homeassistant HTTP/1.1” 204 0 “-” “python-requests/2.24.0” 4040
0669-df17-11ea-92c1-88d7f6c6331b 2631
Aug 15 11:49:27 automation-server influxd(1218): (httpd) 127.0.0.1 – root (15/Aug/2020:11:49:27 -0500) “POST /write?db=homeassistant HTTP/1.1” 204 0 “-” “python-requests/2.24.0” 4809
7cdb-df17-11ea-92c2-88d7f6c6331b 2708

Aug 15 12:15:12 automation-server systemd-modules-load(488): Inserted module 'ppdev'
Aug 15 12:15:12 automation-server systemd-modules-load(488): Inserted module 'parport_pc'
Aug 15 12:15:12 automation-server systemd-modules-load(488): Inserted module 'vhci_hcd'
Aug 15 12:15:12 automation-server systemd(1): Mounted Huge Pages File System.
Aug 15 12:15:12 automation-server systemd(1): Mounted POSIX Message Queue File System.
Aug 15 12:15:12 automation-server systemd(1): Mounted RPC Pipe File System.
Aug 15 12:15:12 automation-server systemd(1): Mounted Kernel Debug File System.
Aug 15 12:15:12 automation-server systemd(1): Mounted Kernel Trace File System.
Aug 15 12:15:12 automation-server systemd(1): Finished Set the console keyboard layout.
Aug 15 12:15:12 automation-server systemd(1): Finished Create list of static device nodes for the current kernel.
Aug 15 12:15:12 automation-server systemd(1): modprobe@drm.service: Succeeded.
Aug 15 12:15:12 automation-server systemd(1): Finished Load Kernel Module drm.
Aug 15 12:15:12 automation-server systemd(1): Finished Load Kernel Modules.
Aug 15 12:15:12 automation-server systemd(1): Finished Remount Root and Kernel File Systems.
Aug 15 12:15:12 automation-server systemd(1): Finished Uncomplicated firewall.
Aug 15 12:15:12 automation-server systemd(1): Activating swap /swapfile...

There is never anything in /var/crash
I used memtest86 to do a 4 pass (6 hour) memory test with no errors.

I replaced the boot NVMe SSD and got a freeze after 5 days.

I don’t seem to have any tools for finding the issue on the system as it stands so I’m considering component swapping to attempt to locate a component responsible for the freeze (assuming, hopefully, there is only one). If I swap components to attempt to isolate the problem, here is my guess as to how likely they are to cause this issue. From most likely to least likely:

  1. CPU (Worked fine for more than a year but maybe suffered during the rebuild)
  2. DRAM memory (Testing suggests that it’s good but the test can’t catch everything)
  3. Video card
  4. Power Supply (Seems like problems from it would result in a reset rather than freeze)
  5. Cooling (Temperatures for the CPU and DRAM reported in the BIOS seem fine and the system is lightly loaded during the freezes)
  6. BIOS settings (Since I’m running with optimized defaults, the best I could do is raise voltages and slow clocks. If I do that, is it risk-free? That is can the system become unstable if I go in that direction? I don’t have any intuition on how much to change things, either)

system workload

macos – Viewing Logs on Startup volume that freezes

I have a MacBook Pro (Computer A) which freezes / restarts during startup.

To investigate the problem, I purchased a brand new internal disk and did a basic installation (10.13 – the latest this model supports) on a working MacBook Pro (Computer B). This clean install boots on at least 4 Macs I have at my disposal.

But, on Computer A, it will startup, the progress bar will advance to about 60% and then it will restart and do the same thing. Or it will freeze the second time.

When I booted in Verbose mode, the last lines I got were:

DSMOS has arrived
Unsupported CPU
Unsupported CPU
Unsupported PCH
AppleHDAEngineOutput::performFormatChange (<ptr>, <ptr>, 0)
en2: promiscuous mode enable succeeded
IOConsoleUsers: time(0) 0->0, lll 0, llk1,
IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0

at which point it hung.

I booted Computer B in verbose mode and was able to look at the logs and follow those error messages, but there are many additional lines there that aren’t displayed on the screen during verbose mode startup.

If I boot Computer A in Target Disk mode, I can mount its disk on Computer B, so I don’t believe the SATA cable is the problem.

Ultimately, I’d like to determine what the root of the problem is, but an interim step is to compare the log files from the disks in Computers A and B.

Is it possible to look at the log file from Computer A while accessing its disk as an external disk on Computer B?

(If you have an idea why it might be restarting/hanging, I’d welcome help on that, too.)

nvidia – How to find out why Ubuntu 20.04 freezes?

I installed Ubuntu 20.04 on my Amd Ryzen 5 1600 / Nvidia Gtx 1070 two weeks ago but Ubuntu completely freezes from time to time.

Keyboard and screen stop working completely, mouse sometimes is able to keep moving. I’ve tried using the magic SysRq key but didn’t work. Also tried alf+F1 but didn’t get any response from the system either. Basically I’m left with pressing the power button in order to restart.

Is there any logs or commands I could use to find anything about these freezes? I’m suspecting Nvidia but I don’t know how to verify.

Edit: Found these logs in /var/log/Xorg.1.log.old that showed the time around my computer crashed.

( 1223.234) (EE) client bug: timer event2 debounce: scheduled expiry is in the past (-22ms), your system is too slow
( 1223.234) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-35ms), your system is too slow
( 1488.529) (EE) client bug: timer event2 debounce: scheduled expiry is in the past (-0ms), your system is too slow
( 1488.529) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-13ms), your system is too slow
( 5125.223) (EE) client bug: timer event2 debounce: scheduled expiry is in the past (-14ms), your system is too slow
( 5125.223) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-27ms), your system is too slow
( 6038.321) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-9ms), your system is too slow
( 6206.894) (EE) client bug: timer event2 debounce: scheduled expiry is in the past (-3ms), your system is too slow
( 6206.894) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-16ms), your system is too slow
( 6409.650) (EE) client bug: timer event2 debounce: scheduled expiry is in the past (-9ms), your system is too slow
( 6409.650) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-22ms), your system is too slow
( 10930.426) (EE) client bug: timer event2 debounce: scheduled expiry is in the past (-7ms), your system is too slow
( 10930.426) (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-20ms), your system is too slow

“free -h” result:

              total        used        free      shared  buff/cache   available
Mem:           15Gi       2.5Gi        11Gi       393Mi       1.9Gi        12Gi
Swap:         2.0Gi          0B       2.0Gi

“sysctl vm.swappiness” result:

vm.swappiness = 60

“sudo lshw -C memory” result:

  *-firmware                
       description: BIOS
       vendor: American Megatrends Inc.
       physical id: 0
       version: 1.L0
       date: 12/28/2018
       size: 64KiB
       capacity: 16MiB
       capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb biosbootspecification uefi
  *-memory
       description: System Memory
       physical id: f
       slot: System board or motherboard
       size: 16GiB
     *-bank:0
          description: 2933 MHz (0.3 ns) (empty)
          product: Unknown
          vendor: Unknown
          physical id: 0
          serial: Unknown
          slot: DIMM 0
          clock: 2933MHz (0.3ns)
     *-bank:1
          description: DIMM DDR4 Synchronous Unbuffered (Unregistered) 2933 MHz (0.3 ns)
          product: CMK16GX4M2B3200C16
          vendor: Unknown
          physical id: 1
          serial: 00000000
          slot: DIMM 1
          size: 8GiB
          width: 64 bits
          clock: 2933MHz (0.3ns)
     *-bank:2
          description: 2933 MHz (0.3 ns) (empty)
          product: Unknown
          vendor: Unknown
          physical id: 2
          serial: Unknown
          slot: DIMM 0
          clock: 2933MHz (0.3ns)
     *-bank:3
          description: DIMM DDR4 Synchronous Unbuffered (Unregistered) 2933 MHz (0.3 ns)
          product: CMK16GX4M2B3200C16
          vendor: Unknown
          physical id: 3
          serial: 00000000
          slot: DIMM 1
          size: 8GiB
          width: 64 bits
          clock: 2933MHz (0.3ns)
  *-cache:0
       description: L1 cache
       physical id: 11
       slot: L1 - Cache
       size: 576KiB
       capacity: 576KiB
       clock: 1GHz (1.0ns)
       capabilities: pipeline-burst internal write-back unified
       configuration: level=1
  *-cache:1
       description: L2 cache
       physical id: 12
       slot: L2 - Cache
       size: 3MiB
       capacity: 3MiB
       clock: 1GHz (1.0ns)
       capabilities: pipeline-burst internal write-back unified
       configuration: level=2
  *-cache:2
       description: L3 cache
       physical id: 13
       slot: L3 - Cache
       size: 16MiB
       capacity: 16MiB
       clock: 1GHz (1.0ns)
       capabilities: pipeline-burst internal write-back unified
       configuration: level=3

Ubuntu 20.04 suddenly freezes in dock menu and does not respond

Even though my pc have enough hardware for system OS: Ubuntu 20.04.1 LTS x86_64 .ossssssssssssssssssdMMMNysssso. Host: HP 250 G6 Notebook PC /ssssssssssshdmmNNmmyNMMMMhssssss/ Kernel: 5.4.0-42-generic +ssssssssshmydMMMMMMMNddddyssssssss+ Uptime: 14 mins /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ Packages: 1693 (dpkg), 16 (snap) .ssssssssdMMMNhsssssssssshNMMMdssssssss. Shell: bash 5.0.17 +sssshhhyNMMNyssssssssssssyNMMMysssssss+ Resolution: 1366x768 ossyNMMMNyMMhsssssssssssssshmmmhssssssso DE: GNOME ossyNMMMNyMMhsssssssssssssshmmmhssssssso WM: Mutter +sssshhhyNMMNyssssssssssssyNMMMysssssss+ WM Theme: Adwaita .ssssssssdMMMNhsssssssssshNMMMdssssssss. Theme: Yaru-dark (GTK2/3) /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/ Icons: Yaru (GTK2/3) +sssssssssdmydMMMMMMMMddddyssssssss+ Terminal: gnome-terminal /ssssssssssshdmNNNNmyNMMMMhssssss/ CPU: Intel i3-7020U (4) @ 2.300GHz .ossssssssssssssssssdMMMNysssso. GPU: AMD ATI Radeon HD 8670A/8670M/8 -+sssssssssssssssssyyyssss+- GPU: Intel HD Graphics 620 :+ssssssssssssssssss+: Memory: 2486MiB / 7878MiB It suddenly freezes in the dock menu while browsing and all icons fade away. Moreover, it does not even respond when I try Xkill command.(Dock menu)(1)