Adding JS to ckeditor frame

I would like to add js script to the ckeditor frame similar to how it is done with css.
I am aware that to do so with css you simply do
ckeditor_stylesheets:
– css/custom-styles.css

How can I achieve the same with js?

8 – Getting Error while adding link in existing quote from embed entity in ckeditor

There is a requirement from our client where they will be able to use ckeditor create quote. So we changed the quote paragrah field field_quote_quote from plain text to formatted text. So we were able to have the quote in ckeditor, All buttons work perfectly fine but when we try use the link button we are able to create a new quote but editing same quote through this error [error here]: Here are the steps to reproduce it.

I have an option to add Quote from ckeditor tool. I have created an option to add quote from ckeditor tools. I have achieved this through embed button from Home >> Administration >> Configuration >> Content authoring .

Here is the steps to add quote:

  1. click on quote icon from ckeditor.
  2. A again ckeditor will open to add the quote.
  3. We add the quote and formatted text and added a link through Link option from ckeditor
  4. Now quote is added successfully while submitting it.

But now issue is occurred when I go for edit the existing quote. Here is the steps to edit the quote:

  1. Click right click on quote.
  2. A ckeditor will be open to add link on existing quote.
  3. Here I click on Link button from a ckeditor to add Link.
  4. Here unable to submit the save button of add link popup.
    Getting error in console:
    Uncaught TypeError: Cannot read property ‘getRanges’ of null

We tried adding using other link plugin like anchor link, ckeditor, entity link, linkit, but all have similar behaviour. We are able to create but not update the link.

Also I am attaching the screenshots for the above mentioned steps
enter image description here

enter image description here

8 – CKEditor strips all inline CSS and some tokens

I’m trying to add a color and font size to some text using the CKEditor. As soon as I save it these are stripped out.
I’ve also noticed some tokens are stripped down when certain settings are enabled.

I went to add a bit of text in a different font and color but when I saved it and viewed the text the spans were stripped of their “style” tag.
I went to config/content/formats/manage and enabled Limit allowed HTML and added span to the list like so :

<a hreflang href> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol type start> <li> 
<dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id> <img src alt data-entity-type data-entity-uuid> 
<u> <s> <p> <h1> <pre> <table> <caption> <tbody> <thead> <tfoot> <th> <td> <tr> <span style>

After saving this all the attributes inside of span are still stripped. I also noticed that many of the tokens I was using (such as site:url) are broken and only half of it remains.

I went back and disabled the Limit allowed HTML option and then when I saved the text the styles and token would save properly.
When viewing the text in an email, the tokens had worked just fine but the span had it’s css striped.

I’ve tried looking for an answer but most are saying I need to enable and add the span to the limit html option but this definitely does not work for me.

There is also Correct faulty HTML enabled, would that be a problem for this?
How can I enable in line styling with the CKEditor?

8 – CKeditor doesn’t work in controller response within a default theme

In a Drupal 8 project I’ve a controller which returns a form that contains a text_format field.

CKeditor is working perfectly in my administration theme (Stable), but it does not on the default theme.

I’ve tried to attach ckeditor core module libraries to the controller returned response with no results.

The role which I test with has permissions “Use simple HTML text format”, “Use full HTML text format”, also the role is checked on /admin/config/content/formats/manage/basic_html also on /admin/config/content/formats/manage/full_html.

my_module/src/Controller/MyController.php :

<?php

namespace Drupalmy_moduleController;

use DrupalCoreControllerControllerBase;
use DrupaluserEntityUser;

/**
 * Provide user form.
 */
class MyController extends ControllerBase {

  /**
   * Return page content.
   */
  public function content() {
    // Load user edit form.
    $entity = User::load(Drupal::currentUser()->id());
    $formObject = Drupal::entityTypeManager()
      ->getFormObject('user', 'default')
      ->setEntity($entity);
    $form = Drupal::formBuilder()->getForm($formObject);
    $render = Drupal::service('renderer');
    $render_form = $render->renderPlain($form);
    return (
      '#theme' => 'customize_user_form',
      '#form' => $render_form,
      '#attached' => (
        // Attach ckeditor core module libraries.
        'library' => (
          'ckeditor/drupal.ckeditor',
          'ckeditor/drupal.ckeditor.stylescombo.admin',
          'ckeditor/drupal.ckeditor.admin',
          'ckeditor/drupal.ckeditor.plugins.drupalimagecaption',
        ),
      ),
    );
  }

}

Results:

enter image description here

Any suggestions?

Many thanks.

How to integrate CKEditor in a PHP Laravel project

I am following a series of videos to learn Laravel. The point is that in one of them they ask me to run in the terminal

composer require unisharp/laravel-ckeditor

but it marks error

Using version ^4.7 for unisharp/laravel-ckeditor
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for unisharp/laravel-ckeditor ^4.7 -> satisfiable by unisharp/laravel-ckeditor(4.7.2).
    - Conclusion: remove laravel/framework v7.8.1
    - Conclusion: don't install laravel/framework v7.8.1
    - unisharp/laravel-ckeditor 4.7.2 requires illuminate/support ~5.0 -> satisfiable by illuminate/support(5.0.x-dev, 5.1.x-dev, 5.2.x-dev, 5.3.x-dev, 5.4.x-dev, 5.5.x-dev, 5.6.x-dev, 5.7.17, 5.7.18, 5.7.19, 5.7.x-dev, 5.8.x-dev, v5.0.0, v5.0.22, v5.0.25, v5.0.26, v5.0.28, v5.0.33, v5.0.4, v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8, v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.45, v5.2.6, v5.2.7, v5.3.0, v5.3.16, v5.3.23, v5.3.4, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41, v5.5.43, v5.5.44, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.36, v5.6.37, v5.6.38, v5.6.39, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9, v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.15, v5.7.2, v5.7.20, v5.7.21, v5.7.22, v5.7.23, v5.7.26, v5.7.27, v5.7.28, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7,
v5.7.8, v5.7.9, v5.8.0, v5.8.11, v5.8.12, v5.8.14, v5.8.15, v5.8.17, v5.8.18, v5.8.19, v5.8.2, v5.8.20, v5.8.22, v5.8.24, v5.8.27, v5.8.28,
v5.8.29, v5.8.3, v5.8.30, v5.8.31, v5.8.32, v5.8.33, v5.8.34, v5.8.35, v5.8.36, v5.8.4, v5.8.8, v5.8.9).
    - don't install illuminate/support 5.5.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.16|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.17|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.2|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.33|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.34|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.35|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.36|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.37|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.39|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.40|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.41|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.43|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.5.44|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.6.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.1|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.10|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.11|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.12|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.13|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.14|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.15|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.16|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.17|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.19|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.2|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.20|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.21|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.22|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.23|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.24|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.25|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.26|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.27|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.29|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.3|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.30|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.31|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.32|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.33|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.34|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.35|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.36|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.37|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.38|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.39|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.4|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.5|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.6|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.7|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.8|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.6.9|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.7.17|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.7.18|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.7.19|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.7.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.1|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.10|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.11|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.15|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.2|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.20|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.21|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.22|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.23|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.26|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.27|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.3|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.4|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.5|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.6|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.7|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.8|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.7.9|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.8.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.11|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.12|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.14|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.15|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.17|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.18|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.19|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.2|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.20|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.22|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.24|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.27|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.29|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.3|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.30|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.31|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.32|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.33|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.34|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.35|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.36|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.4|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.8|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.8.9|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.0.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.1.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.2.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.3.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support 5.4.x-dev|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.22|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.25|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.26|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.33|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.0.4|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.1|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.13|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.16|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.2|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.20|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.22|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.25|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.30|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.31|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.41|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.6|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.1.8|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.19|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.21|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.24|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.25|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.26|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.27|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.28|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.31|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.32|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.37|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.43|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.45|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.6|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.2.7|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.3.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.3.16|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.3.23|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.3.4|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.0|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.13|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.17|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.19|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.27|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.36|don't install laravel/framework v7.8.1
    - don't install illuminate/support v5.4.9|don't install laravel/framework v7.8.1
    - Installation request for laravel/framework (locked at v7.8.1, required as ^7.0) -> satisfiable by laravel/framework(v7.8.1).


Installation failed, reverting ./composer.json to its original content.

I would like to continue with the videos, could someone explain to me how to solve this error?

An option to "fix it" said to use

composer require ckeditor/ckeditor

which does not throw error, but I stay there because I no longer know how to continue with the tutorial …

The next part of the tutorial says I should write to app.php, in section providers, This line

UnisharpCkeditorServiceProvider::class,

and then use the following in the terminal

php artisan vendor:publish --tag=ckeditor

But this last brand error

In ProviderRepository.php line 208:

  Class 'UnisharpCkeditorServiceProvider' not found

Which sounds obvious to me because I did not install that package, but ckeditor / ckeditor. The only thing I could think of was to change the line in app.php to this

CkeditorCkeditorServiceProvider::class,

But make the same mistake above.

Thanks for your support!

ckeditor does not preview image tag

I am working on Drupal 8 and I am using images instead of imag tags. To take advantage of the responsiveness feature. I'm just facing and issuing that CKeditor can't preview the pisture tag. Any ideas how to fix it? enter the image description here

CKEditor 5 documents with django

I am using CKEditor 5 and I cannot activate document mode.
my models.py
the django.db import models
from django.utils.text import slugify
RichTextField is imported from ckeditor.fields

Post class (models.model):

title = models.CharField(max_length=25, blank=True, null=True)
# description = models.TextField(blank=True, null=True)
description = RichTextField(blank=True, null=True)
body = models.TextField(blank=True, null=True)
order = models.IntegerField(blank=True, null=True)

slug = models.SlugField(default='', blank=True)

def save(self):
    self.slug = slugify(self.title)
    super(Post, self).save()

def __str__(self):
    return '%s' % self.title

my html




    
{% csrf_token %}
{{form.description | safe}}
{{form.media}}

I tried it that way https://github.com/leonvelicea/ckeditor5-build-document-mentions but it didn't work.
I need a way to change the description display so that it is edited with the document.

8 – How do I automatically put width and height in img field in CKEditor?

How do I automatically put width and height in img field in CKEditor?

I am making my site AMP compliant. I'm struggling to convert to .

I already managed to convert to doing a custom twig filter, but I have a problem to fill the width and height attribute of the image, because in Drupal CMS, when you load an image into the CKEditor field, it doesn't fill the width and height attribute.

In the Allowed HTML tagsI already added this:


How can I automatically add width and height attribute to image when I upload image to CKEditor?

php – Ckeditor go through ajax

Hello good, how about I need your help to pass the parameters of the ckeditor through ajax. I have it in modal sale.

I have the form so the ajax is in .js that does the operation of saving the data:


        $( "#add_noticia" ).submit(function( event ) {
         var parametros = $(this).serialize();
         var data = new FormData(this);

            $.ajax({
                    type: "POST",
                    url: "ajax/guardar_noticia.php",
                    data: parametros,
                    cache: false,
                    data: data,
                    processData: false, 
                    contentType: false, 
                    success: function (resultado) {          
                    },
                    beforeSend: function(objeto){
                        $("#resultados").html("Enviando...");
                      },
                    success: function(datos){
                    $("#resultados").html(datos);
                    load(1);
                    $('#addNoticiaModal').modal('hide');
                  }
            });
          event.preventDefault();
        });

Can you help me please.

8 – How to update / render the image element within the CKEditor text area field by altering EditorImageDialog

Via RouteSubscriber I altered CkeditorImageStyleImageDialog and change the loaded image element and I need to collect the change in some closed or closed dialog event. The main point is to show the cropped image after closing the image dialog box.
In submitForm I cropped the image, but when I close the image dialog box, my changes are not displayed, but after updating / saving / turning off / on the source button everything works.
What I missed? Any advice?

Video problem