qt4 – Building qt 4.8 from the source for macOS

I have problems with the construction of Qt4.8.7 from my macOS (currently 10.14).
I'm following the instructions from here, but when I run
./configure
I find a warning
Warning: & # 39; LSFindApplicationForInfo & # 39; is in disuse: first obsolete in macOS 10.10 – Use LSCopyApplicationURLsForBundleIdentifier instead
and then an error
warning: include the path for the stdlibc ++ headers not found; pass & # 39; -stdlib = libc ++ & # 39; on the command line to use the standard libc ++ library instead [-Wstdlibcxx-not-found]
In the included file of project.cpp: 42:
In the included ./project.h:45 file:
In the included file from /Users/opentechiz/qt-everywhere-opensource-src-4.8.7/include/QtCore/qstringlist.h:1:
In the included file from /Users/opentechiz/qt-everywhere-opensource-src-4.8.7/include/QtCore/../../src/corelib/tools/qstringlist.h:47:
In the file included from /Users/opentechiz/qt-everywhere-opensource-src-4.8.7/include/QtCore/qlist.h:1:
In the included file from /Users/opentechiz/qt-everywhere-opensource-src-4.8.7/include/QtCore/../../src/corelib/tools/qlist.h:45:
In the included file from /Users/opentechiz/qt-everywhere-opensource-src-4.8.7/include/QtCore/qiterator.h:1:
/Users/opentechiz/qt-everywhere-opensource-src-4.8.7/include/QtCore/../../src/corelib/tools/qiterator.h:50:11: fatal error: file & # 39; new & # 39;

Could someone give me an idea of ​​what the error is and how to fix it? Or a link to a guide to compile Qt4.8 in macOS?