magento2 – This is not implemented, as it is not possible to implement Argon2i with acceptable performance in pure-PHP

This error occurs with Magento 2.4.2 when php does not include the sodium php extension.

You can check if this extension is installed with

php -i | grep sodium
sodium support => enabled
libsodium headers version => 1.0.16

To fix this problem install the sodium php extension.

NOTE the supported PHP version for Magento 2.4 is PHP 7.4