java – Compiling an old version of Minecraft Server to take care of META-INF

I'm trying to run the oldest server version of Minecraft

If I try to execute it, it says something about the OL & # 39; META-INF folder and it does not run. When I looked at it, I found that I would need to compile it.

I just loaded it in IntelliJ and I can not compile it, there is no code.

The file is https://mewe.com/api/v2/doc/chat/UserChat/5ce21f6e76faf13a7d846bd6/5ce21f6dedf9b41c61ae4d67/1.8.2.zip

Any help or even redirection to some place that can help is appreciated. I've been trying to find an answer for weeks and I'm running out of time (self-imposed deadline)