error during sudo apt-get upgrade in ubuntu 20.04LTS

sudo apt-get update
sudo apt-get upgrade
i am getting this error please help and after trying fix also this error is still active

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done

The following packages have been kept back:
  linux-generic-hwe-20.04 linux-headers-generic-hwe-20.04 linux-image-generic-hwe-20.04
The following packages will be upgraded:
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager libproxy1v5
3 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 72.2 kB of archives.
After this operation, 4,096 B disk space will be freed.
Do you want to continue? [Y/n] Y
Get:1 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-networkmanager amd64 0.4.15-10ubuntu1.1 [5,288 B]
Ign:1 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-networkmanager amd64 0.4.15-10ubuntu1.1
Get:2 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-gsettings amd64 0.4.15-10ubuntu1.1 [18.1 kB]
Ign:2 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-gsettings amd64 0.4.15-10ubuntu1.1
Get:3 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1v5 amd64 0.4.15-10ubuntu1.1 [48.8 kB]
Ign:3 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1v5 amd64 0.4.15-10ubuntu1.1
Get:1 http://security.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-networkmanager amd64 0.4.15-10ubuntu1.1 [5,288 B]
Err:1 http://security.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-networkmanager amd64 0.4.15-10ubuntu1.1
  Undetermined Error [IP: 91.189.91.39 80]
Get:2 http://security.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-gsettings amd64 0.4.15-10ubuntu1.1 [18.1 kB]
Err:2 http://security.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1-plugin-gsettings amd64 0.4.15-10ubuntu1.1
  Undetermined Error [IP: 91.189.91.39 80]
Get:3 http://security.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1v5 amd64 0.4.15-10ubuntu1.1 [48.8 kB]
Err:3 http://security.ubuntu.com/ubuntu focal-updates/main amd64 libproxy1v5 amd64 0.4.15-10ubuntu1.1
  Undetermined Error [IP: 91.189.91.39 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/libp/libproxy/libproxy1-plugin-networkmanager_0.4.15-10ubuntu1.1_amd64.deb  Undetermined Error [IP: 91.189.91.39 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/libp/libproxy/libproxy1-plugin-gsettings_0.4.15-10ubuntu1.1_amd64.deb  Undetermined Error [IP: 91.189.91.39 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/libp/libproxy/libproxy1v5_0.4.15-10ubuntu1.1_amd64.deb  Undetermined Error [IP: 91.189.91.39 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?