Django application error when deploying to heroku


I’m new to python and the Django framework. After some series of learning python and Django, I created a web app. I wanted to deploy it into Heroku platform but I’m caught up with this weird error. I have spent weeks googling and researching and finding solutions but to no avail. One of the errors I couldn’t fix was wrapt==1.12.1) is not available for this stack (heroku-18). I have searched everywhere on the internet and pip installing wrapt==1.12.1 but still, I kept getting the same error. Please I need help in fixing this error. Thank you. The error message is down below.

Error message here