apt – Lxd preventing the update 18.04-18.10 in WSL

Because they are now only installed from the snap store, and I have a problem with the snap store, my Do-release-upgrade is not complete How do I tell apt to stop trying to install lxd so he can finish?

balter @ little-d: / etc / update-manager $ sudo apt clean
balter @ little-d: / etc / update-manager $ sudo dpkg --configure -a
Processing the triggers for ureadahead (0.100.0-20) ...
dpkg: dependency problems prevent the configuration of lxd:
lxd depends on lxd-client (= 3.0.2-0ubuntu1 ~ 18.04.1); but nevertheless:
The lxd-client version in the system is 1: 0.4.

dpkg: lxd error processing package (--configure):
Dependency problems - leaving unconfigured
Processing triggers for initramfs-tools (0.131ubuntu15) ...
Configuring open-iscsi (2.0.874-5ubuntu9) ...
dpkg: dependency problems prevent the configuration of lxd-client:
lxd-client depends on lxd (> = 1: 0.4); but nevertheless:
The lxd version in the system is 3.0.2-0ubuntu1 ~ 18.04.1.

dpkg: lxd-client error processing package (--configure):
Dependency problems - leaving unconfigured
Processing the shots for libc-bin (2.28-0ubuntu1) ...
Processing triggers for systemd (239-7ubuntu10.4) ...
Processing the triggers for man-db (2.8.4-2) ...
Setting final (3) ...
The symbolic link /etc/systemd/system/sysinit.target.wants/finalrd.service → /lib/systemd/system/finalrd.service was created.
Processing triggers for initramfs-tools (0.131ubuntu15) ...
Errors were encountered while processing:
lxd
lxd customer
balter @ little-d: / etc / update-manager $ sudo apt upgrade
Reading the lists of packages ... Done
Dependency tree of the building
Reading state information ... Done
You may want to run & # 39; apt --fix-broken install & # 39; to correct them.
The following packages have unmet dependencies:
lxd: depends: lxd-client (= 3.0.2-0ubuntu1 ~ 18.04.1) but 1: 0.4 is installed
lxd-client: depends: lxd (> = 1: 0.4) but 3.0.2-0ubuntu1 ~ 18.04.1 is installed
E: Dependencies not satisfied. Try & # 39; apt --fix-broken install & # 39; apt no packages (or specify a solution).
balter @ little-d: / etc / update-manager $ sudo apt --fix-broken install
Reading the lists of packages ... Done
Dependency tree of the building
Reading state information ... Done
Correcting dependencies ... Done
The following package was installed automatically and is no longer necessary:
libuv1
Use & # 39; sudo apt autoremove & # 39; sudo apt autoremove & # 39; to eliminate it.
The following additional packages will be installed:
lxd
The following packages will be updated:
lxd
1 updated, 0 newly installed, 0 to delete and 165 not updated.
2 is not completely installed or removed.
Need to obtain 11.1 kB of files.
After this operation, 20.1 MB of disk space will be released.
Do you want to continue? [Y/n] Y
Get: 1 http://archive.ubuntu.com/ubuntu cosmic / main amd64 lxd all 1: 0.4 [11.1 kB]
Retrieved 11.1 kB in 0 s (25.6 kB / s)
Preconfiguring packages ...
(Reading the database ... 28554 files and directories currently installed.)
Preparing to unpack ... / files / lxd_1% 3a0.4_all.deb ...
=> Install the LXD add-on
==> Checking connectivity with the snap store
===> Canceling at the user's request
dpkg: error processing file /var/cache/apt/archives/lxd_1%3a0.4_all.deb (--unpack):
new thread pre-installation script lxd package returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/lxd_1%3a0.4_all.deb
E: The / usr / bin / dpkg thread returned an error code (1)
balter @ little-d: / etc / update-manager $

enter the description of the image here